Bug 1663863 - Missed Metrics and Dashboards links under Monitoring bar
Summary: Missed Metrics and Dashboards links under Monitoring bar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-07 08:47 UTC by Junqi Zhao
Modified: 2019-06-04 10:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Missed Metrics and Dashboards links under Monitoring bar (206.13 KB, image/png)
2019-01-07 08:47 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:49 UTC

Description Junqi Zhao 2019-01-07 08:47:45 UTC
Created attachment 1518917 [details]
Missed Metrics and Dashboards links under Monitoring bar

Description of problem:
This bug is cloned from https://jira.coreos.com/browse/CONSOLE-1176
File it again for QE team to track the monitoring issue.


login cluster console with admin user, and there are not "Metrics" and "Dashboards" links in cluster console under monitoring bar

"Metrics" link should be linked to Prometheus UI of cluster monitoring

"Dashboards" link should be linked to Grafana UI of cluster monitoring

Version-Release number of selected component (if applicable):
openshift version: v0.9.0

payload: quay.io/openshift-release-dev/ocp-release@sha256:e237499d3b118e25890550daad8b17274af93baf855914a9c6f8f07ebc095dea

How reproducible:
Always

Steps to Reproduce:
1. login cluster console with admin user
2.
3.

Actual results:
Missed Metrics and Dashboards links under Monitoring bar

Expected results:
Should have Metrics and Dashboards links under Monitoring bar

Additional info:

Comment 1 Samuel Padgett 2019-01-07 14:20:23 UTC
I don't see the sharing-config config map in the openshift-monitoring namespace, which the cluster monitoring operator should be creating. Changing the component to Monitoring.

❯ oc get configmaps -n openshift-monitoring
NAME                                        DATA      AGE
adapter-config                              1         1m
cluster-monitoring-config                   1         6m
grafana-dashboard-k8s-cluster-rsrc-use      1         5m
grafana-dashboard-k8s-node-rsrc-use         1         5m
grafana-dashboard-k8s-resources-cluster     1         5m
grafana-dashboard-k8s-resources-namespace   1         5m
grafana-dashboard-k8s-resources-pod         1         5m
grafana-dashboards                          1         5m
prometheus-adapter-prometheus-config        1         1m
prometheus-k8s-rulefiles-0                  1         4m
serving-certs-ca-bundle                     1         4m

Comment 4 Junqi Zhao 2019-01-15 10:12:55 UTC
Issue is fixed, image version please see Bug 1666028

Comment 7 errata-xmlrpc 2019-06-04 10:41:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.