Bug 1663998 (CVE-2018-20455, CVE-2018-20456, CVE-2018-20457, CVE-2018-20458, CVE-2018-20459, CVE-2018-20460, CVE-2018-20461) - CVE-2018-20455 CVE-2018-20456 CVE-2018-20457 CVE-2018-20458 CVE-2018-20459 CVE-2018-20460 CVE-2018-20461 radare2: Multiple vulnerabilities
Summary: CVE-2018-20455 CVE-2018-20456 CVE-2018-20457 CVE-2018-20458 CVE-2018-20459 CV...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2018-20455, CVE-2018-20456, CVE-2018-20457, CVE-2018-20458, CVE-2018-20459, CVE-2018-20460, CVE-2018-20461
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1663999
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-07 13:44 UTC by Andrej Nemec
Modified: 2019-09-29 15:04 UTC (History)
1 user (show)

Fixed In Version: radare2 3.1.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:44:49 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2019-01-07 13:44:35 UTC
CVE-2018-20455

In radare2 prior to 3.1.1, the parseOperand function inside libr/asm/p/asm_x86_nz.c may allow attackers to cause a denial of service (application crash via a stack-based buffer overflow) by crafting an input file, a related issue to CVE-2018-20456.

https://github.com/radare/radare2/commit/9b46d38dd3c4de6048a488b655c7319f845af185
https://github.com/radare/radare2/issues/12373

CVE-2018-20456

In radare2 prior to 3.1.1, the parseOperand function inside libr/asm/p/asm_x86_nz.c may allow attackers to cause a denial of service (application crash in libr/util/strbuf.c via a stack-based buffer over-read) by crafting an input file, a related issue to CVE-2018-20455.

https://github.com/radare/radare2/commit/9b46d38dd3c4de6048a488b655c7319f845af185
https://github.com/radare/radare2/issues/12372

CVE-2018-20457

In radare2 through 3.1.3, the assemble function inside libr/asm/p/asm_arm_cs.c allows attackers to cause a denial-of-service (application crash via an r_num_calc out-of-bounds read) by crafting an arm assembly input because a loop uses an incorrect index in armass.c and certain length validation is missing in armass64.c, a related issue to CVE-2018-20459.

https://github.com/devnexen/radare2/commit/88a8adf080a9f8ed5a4250a2507752e133ba54dd
https://github.com/radare/radare2/issues/12417

CVE-2018-20458

In radare2 prior to 3.1.1, r_bin_dyldcache_extract in libr/bin/format/mach0/dyldcache.c may allow attackers to cause a denial-of-service (application crash caused by out-of-bounds read) by crafting an input file.

https://github.com/radare/radare2/commit/4e98402f09a0ef0bb8559a33a4c1988c54938eaf
https://github.com/radare/radare2/issues/12374

CVE-2018-20459

In radare2 through 3.1.3, the armass_assemble function in libr/asm/arch/arm/armass.c allows attackers to cause a denial-of-service (application crash by out-of-bounds read) by crafting an arm assembly input because a loop uses an incorrect index in armass.c and certain length validation is missing in armass64.c, a related issue to CVE-2018-20457.

https://github.com/devnexen/radare2/commit/88a8adf080a9f8ed5a4250a2507752e133ba54dd
https://github.com/radare/radare2/issues/12418

CVE-2018-20460

In radare2 prior to 3.1.2, the parseOperands function in libr/asm/arch/arm/armass64.c allows attackers to cause a denial-of-service (application crash caused by stack-based buffer overflow) by crafting an input file.

https://github.com/radare/radare2/commit/df167c7db545953bb7f71c72e98e7a3ca0c793bf
https://github.com/radare/radare2/issues/12376

CVE-2018-20461

In radare2 prior to 3.1.1, core_anal_bytes in libr/core/cmd_anal.c allows attackers to cause a denial-of-service (application crash caused by out-of-bounds read) by crafting a binary file.

https://github.com/radare/radare2/commit/a1bc65c3db593530775823d6d7506a457ed95267
https://github.com/radare/radare2/issues/12375



CVE-2018-20459 and CVE-2018-20457 are fixed only in master at this time.

Comment 1 Andrej Nemec 2019-01-07 13:44:52 UTC
Created radare2 tracking bugs for this issue:

Affects: fedora-all [bug 1663999]

Comment 2 Product Security DevOps Team 2019-06-10 10:44:49 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.