Bug 166400 - USB drives failures with SCSI drives present.
USB drives failures with SCSI drives present.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-20 09:43 EDT by Larry Linder
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:55:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Linder 2005-08-20 09:43:50 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Can't view data base - kills mozilla  RH 7.1

How reproduced:
RH 7.1, RH 7.3  RH 9.0  RH 2.0 enterprise server evaluation down load.
Requires a SCSI disk system.  Works well with out any SCSI devices attached but
dog slow 3 Gig in 1/2 hr.  1.7 GH Athelon with 1 G ram.

Steps to Reproduce:
1.System must have a scsi device attached with id set to 1
2.plug in usb hard disk.
3.tail /var/log/messages  - gives scsi device such as sda or our system sde
4./sbin/fdisk /dev/sde
5.create file system
6.mkdir /backup
7. mount disk to /backup
8. It looks good from here.
9  vi /proc/scsi/scsi
   you will see that the real hardware is under SCSI0  ID 00
   usb device is                                SCSI1  ID 00
This looks ok from here.
Actual results:
cd to /backup    -   OK
df               1G available used 4
Try to use disk - as in cp -Rp /usr/local   Back up some arbitrary directory
recursively.
First 4K copies and device quits.  You cannot recover by unplugging as it just
creates a new logical drive.  You have to unplug the usb device, reboot.
At this point you can mount the device and you get a warning but it works, you
can see the small directory it created.
If you repeat this without any SCSI devices connected then it works with RH 9.0
but is dog slow 3 G file transfer in 1/2 hr on a fast mach.

Expected results:


Additional info:
There is something wrong with the external USB stuff an that id does not
recognize other devices that are attached.
SCSI does not recognize that there are two SCSI devices as SCSI0 and SCSI1 both
with an ID of 00 and can't differentiate between them.
We are evaluating Linux Enterprise server to replace our Linux 7.1 that has
served us well.and we would like to use the USB devices to create backups for
off site storage.
Comment 1 Suzanne Hillman 2005-08-22 11:26:55 EDT
You're evaluating RHEL2.1, and not RHEL3 or RHEL4? I ask because the current
version setting is confusing, and because this bug is likely to be fixed in
RHEL3, and definitely fixed in RHEL4.

Is there any reason that you're not evaluating our most recent RHEL product?
Comment 2 Ernie Petrides 2005-08-22 17:24:41 EDT
Larry, please try this for RHEL3 or RHEL4 and let us know if you still
have the problem.  If not, please close this as NOTABUG.  If so, please
correct the product version.  (I've tentatively set it to 3.)
Comment 4 RHEL Product and Program Management 2007-10-19 14:55:44 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.