Bug 1664030 - perl-Class-DBI-Plugin-Type-0.02-35.fc30 FTBFS: tests fail with perl-DBD-SQLite-1.62-1.fc30
Summary: perl-Class-DBI-Plugin-Type-0.02-35.fc30 FTBFS: tests fail with perl-DBD-SQLit...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Class-DBI-Plugin-Type
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Keywords:
: 1675621 (view as bug list)
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-01-07 14:49 UTC by Petr Pisar
Modified: 2019-05-08 03:04 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-05-08 01:12:05 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 128135 None None None 2019-01-07 14:49 UTC

Description Petr Pisar 2019-01-07 14:49:06 UTC
perl-Class-DBI-Plugin-Type-0.02-35.fc30 fails to build in Fedora 30 because tests fail:

$ perl -Iblib/{lib,arch} t/1.t 
1..6
ok 1 - use Class::DBI::Plugin::Type;
not ok 2 - notes is text
#   Failed test 'notes is text'
#   at t/1.t line 28.
#                   undef
#     doesn't match '(?^:text|blob)'
not ok 3 - tasted is a date
#   Failed test 'tasted is a date'
#   at t/1.t line 29.
#          got: undef
#     expected: 'date'
not ok 4 - price is decimal
#   Failed test 'price is decimal'
#   at t/1.t line 30.
#                   undef
#     doesn't match '(?^:^decimal)'
not ok 5 - id is integer
#   Failed test 'id is integer'
#   at t/1.t line 31.
#                   undef
#     doesn't match '(?^:^int)'
not ok 6 - name is varchar
#   Failed test 'name is varchar'
#   at t/1.t line 32.
#                   undef
#     doesn't match '(?^:^varchar)'
# Looks like you failed 5 tests of 6.

A difference between passing and failing build root is at <https://apps.fedoraproject.org/koschei/build/5873222>.

This is triggered by upgrading perl-DBD-SQLite from 1.60-1.fc30 to
1.62-1.fc30.

Comment 1 Petr Pisar 2019-02-12 11:39:37 UTC
*** Bug 1675621 has been marked as a duplicate of this bug. ***

Comment 2 Petr Pisar 2019-02-12 11:42:33 UTC
Debian provided a fix in the bug report at CPAN.

Comment 3 Fedora Release Engineering 2019-04-26 23:24:27 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 4 Fedora Update System 2019-04-29 07:50:20 UTC
perl-Class-DBI-Plugin-Type-0.02-37.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a2c23cf4b1

Comment 5 Fedora Update System 2019-04-29 07:55:27 UTC
perl-Class-DBI-Plugin-Type-0.02-36.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40524acabb

Comment 6 Fedora Update System 2019-04-30 02:48:58 UTC
perl-Class-DBI-Plugin-Type-0.02-37.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a2c23cf4b1

Comment 7 Fedora Update System 2019-04-30 03:40:07 UTC
perl-Class-DBI-Plugin-Type-0.02-36.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40524acabb

Comment 8 Fedora Update System 2019-05-08 01:12:05 UTC
perl-Class-DBI-Plugin-Type-0.02-37.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-05-08 03:04:25 UTC
perl-Class-DBI-Plugin-Type-0.02-36.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.