Bug 1664038 - perl-GnuPG-Interface-0.52-11.fc30 FTBFS: test fail after making /usr/bin/gpg GnuPG2
Summary: perl-GnuPG-Interface-0.52-11.fc30 FTBFS: test fail after making /usr/bin/gpg ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-GnuPG-Interface
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Emmanuel Seyman
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
: 1675629 (view as bug list)
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-01-07 15:03 UTC by Petr Pisar
Modified: 2019-04-01 00:00 UTC (History)
4 users (show)

Fixed In Version: perl-GnuPG-Interface-0.52-12.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-01 00:00:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github bestpractical gnupg-interface pull 1 None None None 2019-02-12 12:04:37 UTC
CPAN 102651 None None None 2019-01-07 15:05:19 UTC

Description Petr Pisar 2019-01-07 15:03:04 UTC
perl-GnuPG-Interface-0.52-11.fc30 fails to build in Fedora 30 because tests fail:

t/clearsign.t .............. 
Failed 2/2 subtests 
t/decrypt.t ................ 
Failed 4/4 subtests 
t/detach_sign.t ............ 
Failed 2/2 subtests 
t/encrypt.t ................ ok
t/encrypt_symmetrically.t .. ok
t/export_keys.t ............ ok
t/Fingerprint.t ............ ok
t/get_public_keys.t ........ 
Failed 1/3 subtests 
t/get_secret_keys.t ........ 
Failed 2/2 subtests 
t/import_keys.t ............ ok
t/Interface.t .............. ok
t/list_public_keys.t ....... ok
t/list_secret_keys.t ....... 
Failed 1/4 subtests 
t/list_sigs.t .............. ok
BUILDSTDERR: gpg: using "0xF950DA9C" as default secret key for signing
BUILDSTDERR: gpg: signing failed: No pinentry
BUILDSTDERR: gpg: signing failed: No pinentry
t/passphrase_handling.t .... 
Failed 3/3 subtests 
t/sign.t ................... 
Failed 2/2 subtests 
t/sign_and_encrypt.t ....... 
Failed 2/2 subtests 
t/UserId.t ................. ok
t/verify.t ................. ok
t/wrap_call.t .............. ok
Test Summary Report
-------------------
t/clearsign.t            (Wstat: 0 Tests: 2 Failed: 2)
  Failed tests:  1-2
t/decrypt.t              (Wstat: 0 Tests: 4 Failed: 4)
  Failed tests:  1-4
t/detach_sign.t          (Wstat: 0 Tests: 2 Failed: 2)
  Failed tests:  1-2
t/get_public_keys.t      (Wstat: 0 Tests: 3 Failed: 1)
  Failed test:  3
t/get_secret_keys.t      (Wstat: 0 Tests: 2 Failed: 2)
  Failed tests:  1-2
t/list_secret_keys.t     (Wstat: 0 Tests: 4 Failed: 1)
  Failed test:  2
t/passphrase_handling.t  (Wstat: 0 Tests: 3 Failed: 3)
  Failed tests:  1-3
t/sign.t                 (Wstat: 0 Tests: 2 Failed: 2)
  Failed tests:  1-2
t/sign_and_encrypt.t     (Wstat: 0 Tests: 2 Failed: 2)
  Failed tests:  1-2
Files=20, Tests=52, 15 wallclock secs ( 0.15 usr  0.08 sys + 11.65 cusr  1.94 csys = 13.82 CPU)
Result: FAIL

A difference between passing and failing build root is at <https://apps.fedoraproject.org/koschei/build/5781872>.

This is very probably triggered by replacing gnupg with gnupg2 <https://fedoraproject.org/wiki/Changes/GnuPG2_as_default_GPG_implementation>.

Comment 1 Petr Pisar 2019-02-12 12:03:03 UTC
*** Bug 1675629 has been marked as a duplicate of this bug. ***

Comment 2 Petr Pisar 2019-02-12 12:04:38 UTC
A possible fix is linked from a bug report at CPAN.

Comment 3 Fedora Update System 2019-03-24 17:00:54 UTC
perl-GnuPG-Interface-0.52-12.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-810c0a0e1e

Comment 4 Fedora Update System 2019-03-25 03:48:57 UTC
perl-GnuPG-Interface-0.52-12.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-810c0a0e1e

Comment 5 Fedora Update System 2019-04-01 00:00:57 UTC
perl-GnuPG-Interface-0.52-12.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.