Bug 1664054 - Terminus fonts apparently corrupted
Summary: Terminus fonts apparently corrupted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: terminus-fonts
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans Ulrich Niedermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-07 15:41 UTC by Tom Horsley
Modified: 2019-02-12 02:55 UTC (History)
2 users (show)

Fixed In Version: terminus-fonts-4.47-3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-12 02:55:21 UTC


Attachments (Terms of Use)

Description Tom Horsley 2019-01-07 15:41:41 UTC
Description of problem:
Installed updates today, which included new terminus fonts. Apps (like emacs) which used terminus went completely wacko. Just one example: emacs frame properties reports width is 101 characters, yet when I type characters manually across the screen, the width is actually 81 characters. All problems disappeared when I did a dnf-downgrade. The fonts which I downgraded to (and which work fine) are:

terminus-fonts-4.40-9.fc29.noarch
terminus-fonts-console-4.40-9.fc29.noarch


Version-Release number of selected component (if applicable):
The broken versions I backed off of were:

terminus-fonts-4.46-2.fc29.noarch.rpm
terminus-fonts-console-4.46-2.fc29.noarch.rpm

How reproducible:
It was 100% while I had the new versions installed, don't really want to try installing them again.

Steps to Reproduce:
1. dnf update
2. get new terminus fonts
3. see wacky behavior.

Actual results:
Messed up fonts

Expected results:
Normal fonts

Additional info:

Comment 1 Hans Ulrich Niedermann 2019-01-08 08:04:31 UTC
Very interesting. I cannot reproduce this on my F28 system. Will try to reproduce on F29 system.

Comment 2 Tom Horsley 2019-01-08 11:08:28 UTC
Here's some details about exactly what I was doing. The emacs with the problems was an old version running on a old system and connecting to my fedora 29 desktop via ssh X forwarding.

https://lists.fedoraproject.org/archives/list/users@lists.fedoraproject.org/thread/27DFUJUJWL3HDLUTACQKXZIVEM4ZRWUL/

Comment 3 Tom Horsley 2019-01-08 13:27:21 UTC
I also think the iso8859 registry disappeared. I had some font specs in an old motif app like these:

Nlaunch*smallFontList:      -*-terminus-medium-r-*-*-20-*-*-*-*-*-iso8859-*
Nlaunch*fixedFontList:      -*-terminus-medium-r-*-*-20-*-*-*-*-*-iso8859-*
Nlaunch*smallFixedFontList: -*-terminus-medium-r-*-*-20-*-*-*-*-*-iso8859-*

and that app didn't display normally with the new terminus fonts, and xfontsel didn't show iso8859 as a choice.

Comment 4 Hans Ulrich Niedermann 2019-01-15 11:52:38 UTC
The following is a collection of thoughts, findings and
comments I just had while trying to reproduce the problem.

So to reproduce this, I need both a very old Fedora system,
and a very new Fedora system?

terminus-4.46 uses a new way to build the fonts compared to
terminus-4.40, so that probably is the cause of the change.

The issue might be solved in the terminus-4.46 font files,
the old emacs, the old X11 libraries, the X11 fontserver,
or somewhere else still.

Hmm. It could indeed be the iso8859 vs iso10646 issue
you called "registry". 

$ xlsfonts | grep -i terminus
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso10646-1
-xos4-terminus-bold-r-normal--14-140-72-72-c-80-iso10646-1
-xos4-terminus-bold-r-normal--16-160-72-72-c-80-iso10646-1
-xos4-terminus-bold-r-normal--18-180-72-72-c-100-iso10646-1
-xos4-terminus-bold-r-normal--20-200-72-72-c-100-iso10646-1
-xos4-terminus-bold-r-normal--22-220-72-72-c-110-iso10646-1
-xos4-terminus-bold-r-normal--24-240-72-72-c-120-iso10646-1
-xos4-terminus-bold-r-normal--28-280-72-72-c-140-iso10646-1
-xos4-terminus-bold-r-normal--32-320-72-72-c-160-iso10646-1
-xos4-terminus-medium-r-normal--12-120-72-72-c-60-iso10646-1
-xos4-terminus-medium-r-normal--14-140-72-72-c-80-iso10646-1
-xos4-terminus-medium-r-normal--16-160-72-72-c-80-iso10646-1
-xos4-terminus-medium-r-normal--18-180-72-72-c-100-iso10646-1
-xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso10646-1
-xos4-terminus-medium-r-normal--22-220-72-72-c-110-iso10646-1
-xos4-terminus-medium-r-normal--24-240-72-72-c-120-iso10646-1
-xos4-terminus-medium-r-normal--28-280-72-72-c-140-iso10646-1
-xos4-terminus-medium-r-normal--32-320-72-72-c-160-iso10646-1
$

I see the above output if I run this from a gnome-terminal on my F29 PC with
terminus-4.46 over an "ssh -X" connection to a Raspberry Pi running Fedora 29,
and one Raspberry Pi running some older version of Raspbian. The oldest
version of emacs available on the Raspbian is the emacs23 package, so I
installed that for testing .

After downgrading the F29 PC to terminus-4.40 the xlsfonts
command ends up showing *MANY* more lines. I have just shown the
size 12 ones down below:

$ xlsfonts | grep -i terminus
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso10646-1
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso8859-1
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso8859-13
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso8859-15
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso8859-16
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso8859-2
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso8859-5
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso8859-7
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso8859-9
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-koi8-r
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-koi8-u
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-microsoft-cp1251
-xos4-terminus-bold-r-normal--12-120-72-72-c-60-paratype-pt154
[... similar/same for sizes 14,16,18,20,22,24,28,32, and medium instead of bold ...]
$

This now allows me to customize the ssh-X-connected emacs23
to actually use the Terminus family for the default font.

So it looks like we actually do need to build and install
all those variants after all, and the new build system in
terminus-4.46 skips them.

I will test that in the next step by having the terminus-4.46
package build all the font versions other than iso10646-1.

Comment 5 Tom Horsley 2019-01-15 12:28:30 UTC
Might be reproducible with any X program using an old toolkit like motif or lesstif where the fonts come from the X server and are not rendered directly by the program. Don't know that it only happens with remote programs, that may just be the example I happened to notice first.

Comment 6 Hans Ulrich Niedermann 2019-01-15 16:53:00 UTC
I have just re-added all those missing PCF fonts, and have a test build at https://koji.fedoraproject.org/koji/taskinfo?taskID=32046593 with a package at https://kojipkgs.fedoraproject.org//work/tasks/6593/32046593/terminus-fonts-4.46-3.fc29.noarch.rpm

Could you try that? Does this fix your issue?

Hoping this will fix it, and translates easily to the 4.47 released just no while I was looking elsewhere.

Comment 7 Hans Ulrich Niedermann 2019-01-15 17:52:05 UTC
I have just run test builds for 4.47 for

    F28: https://koji.fedoraproject.org/koji/buildinfo?buildID=1179993
    F29: https://koji.fedoraproject.org/koji/buildinfo?buildID=1179990
    F30: https://koji.fedoraproject.org/koji/buildinfo?buildID=1179989

Does that fix your ancient emacs?

I cannot find any ancient lesstif based binaries here, so testing that
does not really work.

Comment 8 Tom Horsley 2019-01-15 23:52:35 UTC
The 4.47 f29 build does indeed appear to fix the problems I was seeing with emacs. Thanks! I didn't try the 4.46-3 version since I figured 4.47 was newer.

Comment 9 Fedora Update System 2019-01-16 01:53:58 UTC
terminus-fonts-4.47-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-519b0d2814

Comment 10 Fedora Update System 2019-01-16 01:54:02 UTC
terminus-fonts-4.47-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ce0cfddb1b

Comment 11 Hans Ulrich Niedermann 2019-01-16 01:55:27 UTC
Thanks a lot for your report and your help with fixing it!

The updates will now work their way down the normal updates channel.

Comment 12 Fedora Update System 2019-01-17 02:11:19 UTC
terminus-fonts-4.47-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-519b0d2814

Comment 13 Fedora Update System 2019-01-17 02:50:25 UTC
terminus-fonts-4.47-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ce0cfddb1b

Comment 14 Fedora Update System 2019-02-12 02:55:21 UTC
terminus-fonts-4.47-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.