Bug 166413 - RTL8139 times out if acpi=on
RTL8139 times out if acpi=on
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
http://www.ussg.iu.edu/hypermail/linu...
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-20 14:45 EDT by Rakotomandimby Mihamina
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 14:31:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rakotomandimby Mihamina 2005-08-20 14:45:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
My Ethernet network hangs as shown in the URL, exactly.
I have a CompaQ R4000 (same as HP zv6000), with a RTL8139 NIC.
To have the network working I must off the acpi and it is a real problem on a notebook. :-)

Version-Release number of selected component (if applicable):
kernel-2.6+

How reproducible:
Always

Steps to Reproduce:
1. not apend "acpi=off" as option at boot.
2. boot
3.
  

Actual Results:  ethernet network works some seconds, then hangs. (as well as static IP adressing and DHCP)


Expected Results:  network should goes on


Additional info:
Comment 1 Dave Jones 2005-08-26 19:17:15 EDT
please try the latest errata kernel from updates-testing. This has a large acpi
update which may fix this problem.
Comment 2 Dave Jones 2005-09-30 03:18:30 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 3 Dave Jones 2005-11-10 15:26:37 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 4 Rakotomandimby Mihamina 2005-11-14 16:24:33 EST
It did not fix. Same error messages. I am very confused, I really want to help
but I think it is because of my hardware... not very "Linux compliant"...
Comment 5 John W. Linville 2005-12-02 14:21:39 EST
Have you tried "acpi=noirq" as an alternative?  That may restore some of your 
ACPI function. 
 
Beyond that, I'm not sure what I can do.  Most often these problems result 
from problems in the BIOS itself.  Have you looked for a BIOS update from your 
manufacturer? 
Comment 6 John W. Linville 2006-01-09 14:31:37 EST
Closed due to lack of response.  Please reopen when the requested information 
becomes available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.