Bug 1664145 - Openshift 4.1 has broken storage features because of multizone deployments
Summary: Openshift 4.1 has broken storage features because of multizone deployments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Bradley Childs
QA Contact: Chao Yang
URL:
Whiteboard:
: 1683750 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-07 20:48 UTC by Hemant Kumar
Modified: 2019-06-04 10:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:49 UTC

Description Hemant Kumar 2019-01-07 20:48:55 UTC
Because of multizone deployments of cluster some storage features might be broken. For example - 2PVCs in use by same pod can break.

Comment 1 Hemant Kumar 2019-01-07 20:49:14 UTC
xref https://github.com/openshift/origin/pull/21730

Comment 2 Jan Safranek 2019-01-08 15:21:12 UTC
I am confused, https://github.com/openshift/origin/pull/21730 disables two tests that don't use any volumes. Do we actually have any test that needs 2 PVCs?

Comment 5 Matthew Wong 2019-03-14 17:25:48 UTC
*** Bug 1683750 has been marked as a duplicate of this bug. ***

Comment 7 Chao Yang 2019-03-21 07:03:38 UTC
It is passed on OCP build: 4.0.0-0.nightly-2019-03-20-153904

1.Create 2 dynamic pvc, pvc is in pending status
2.Create one pod
apiVersion: v1
kind: Pod
metadata:
  name: my-lamp-site
spec:
    containers:
    - name: mysql
      image: aosqe/hello-openshift
      volumeMounts:
      - mountPath: /var/lib/mysql
        name: site-data
        subPath: mysql
    - name: php
      image: jhou/hello-openshift
      volumeMounts:
      - mountPath: /mnt/html
        name: site-data
        subPath: html
    volumes:
    - name: site-data
      persistentVolumeClaim:
        claimName: ebsc
3.Pod is running

Comment 10 errata-xmlrpc 2019-06-04 10:41:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.