Bug 1664181 - Blobby AI scripts not working
Summary: Blobby AI scripts not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blobby
Version: 28
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-08 00:49 UTC by Kevin Kofler
Modified: 2019-01-23 01:45 UTC (History)
2 users (show)

Fixed In Version: blobby-1.0-19.svn1681.fc29 blobby-1.0-19.svn1681.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-16 02:19:35 UTC
Type: Bug


Attachments (Terms of Use)
blobby-install-api-lua-files.patch (513 bytes, patch)
2019-01-08 20:47 UTC, Kevin Kofler
no flags Details | Diff

Description Kevin Kofler 2019-01-08 00:49:51 UTC
Description of problem:
All the AI scripts in Blobby Volley 2 (blobby) are failing to load. As a result, the AI does not move at all and it is impossible to play against the AI.

Version-Release number of selected component (if applicable):
blobby-1.0-17.svn1681.fc28.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start Blobby Volley 2.
2. Configure it to play against any of the AI scripts.
3. Start the game.

Actual results:
All scripts produce the same errors:
Warning: impossible to get value of unknown configuration variable bot_debug
Couldn't load api.lua: not found
Script Error: Could not create LuaGameLogic: 
Couldn't load api.lua: not found
              Using fallback ruleset
and the AI does not move at all.

Expected results:
No errors and the AI actually plays.

Additional info:
This worked fine in previous Fedora releases (up to Fedora 27), which shipped the older blobby-1.0-11.svn1541.fc24 build.

Comment 1 Kevin Kofler 2019-01-08 00:58:23 UTC
Downgrading to blobby-1.0-11.svn1541.fc24 with "sudo dnf --releasever=27 distro-sync blobby" "fixes" the issue, so it is really the blobby package causing the issue and not some system library.

Comment 2 Kevin Kofler 2019-01-08 01:07:22 UTC
The SVN snapshot in F27 was from 2014, F28 has a snapshot from 2018. Unfortunately, it goes without saying that a lot of things changed in those 4 years, so I cannot figure out what upstream change broke things just by going through their SVN log.

Comment 3 Kevin Kofler 2019-01-08 20:06:34 UTC
I found out how to fix it: you have to install the files:
* data/api.lua to /usr/share/blobby/api.lua
* data/bot_api.lua to /usr/share/blobby/bot_api.lua
* data/rules_api.lua to /usr/share/blobby/rules_api.lua

I used the following workaround:
su -
cd /usr/share/blobby
wget 'https://sourceforge.net/p/blobby/code/HEAD/tree/trunk/data/api.lua?format=raw' -O api.lua
wget 'https://sourceforge.net/p/blobby/code/HEAD/tree/trunk/data/bot_api.lua?format=raw' -O bot_api.lua
wget 'https://sourceforge.net/p/blobby/code/HEAD/tree/trunk/data/rules_api.lua?format=raw' -O rules_api.lua
logout

With that workaround, the current snapshot (blobby-1.0-17.svn1681.fc28.x86_64) works for me, but those files must be included in the package.

Comment 4 Kevin Kofler 2019-01-08 20:47:30 UTC
Created attachment 1519284 [details]
blobby-install-api-lua-files.patch

The attached patch (to data/CMakeLists.txt) should fix the issue.

Comment 5 Kevin Kofler 2019-01-12 06:14:52 UTC
Ping? Do you want me to do the update for you? (I'm a provenpackager.)

Comment 6 Ankur Sinha (FranciscoD) 2019-01-12 09:14:34 UTC
(In reply to Kevin Kofler from comment #5)
> Ping? Do you want me to do the update for you? (I'm a provenpackager.)

Hi Kevin,

Sorry for the delay. Yes, please go ahead and apply the patch. Thank you!

Ankur

Comment 7 Kevin Kofler 2019-01-12 13:15:13 UTC
I applied the patch in Rawhide, but the builds are stuck because of the Koji (s390x builder) outage that lasts the whole weekend. I will take care of the rest when Koji goes back to normal operation.

Comment 8 Fedora Update System 2019-01-14 02:33:58 UTC
blobby-1.0-19.svn1681.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-75c79e688d

Comment 9 Fedora Update System 2019-01-14 02:34:01 UTC
blobby-1.0-19.svn1681.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bad386fceb

Comment 10 Fedora Update System 2019-01-15 02:23:22 UTC
blobby-1.0-19.svn1681.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-75c79e688d

Comment 11 Fedora Update System 2019-01-15 03:30:29 UTC
blobby-1.0-19.svn1681.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bad386fceb

Comment 12 Fedora Update System 2019-01-16 02:19:35 UTC
blobby-1.0-19.svn1681.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-01-23 01:45:46 UTC
blobby-1.0-19.svn1681.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.