Bug 166420 - ntpd exited with preempt_count 1
ntpd exited with preempt_count 1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-20 16:53 EDT by Joe Acosta
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 09:20:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ntp-4.2.0.a.20050816-2.src.rpm (3.91 MB, application/x-rpm)
2006-01-05 07:43 EST, Petr Raszyk
no flags Details

  None (edit)
Description Joe Acosta 2005-08-20 16:53:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Fedora/1.7.10-1.5.1

Description of problem:
Kernel preemt oops

not sure if this is ntp or the kernel

Version-Release number of selected component (if applicable):
ntp-4.2.0.a.20040617-8

How reproducible:
Didn't try

Steps to Reproduce:
1. run ntpd
2. look at dmesg
3. see the oops
  

Actual Results:  Unable to handle kernel NULL pointer dereference at virtual address 00000000
 printing eip:
c012f487
*pde = 34bc2067
*pte = 00000000
Oops: 0002 [#1]
PREEMPT
Modules linked in: pl2303 usbserial via686a eeprom i2c_sensor i2c_isa af_packet ipt_REJECT ipt_LOG ipt_limit ipt_state ip_conntrack iptable_filter ip_tables usbhid pwc videodev v4l2_common ohci1394 ieee1394 uhci_hcd parport_pc parport i2c_viapro snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_emul snd_emu10k1 snd_rawmidi snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc snd_util_mem snd_hwdep snd soundcore tulip sr_mod sym53c8xx scsi_transport_spi ide_floppy usbcore evdev
CPU:    0
EIP:    0060:[<c012f487>]    Not tainted VLI
EFLAGS: 00010002   (2.6.12-1.1398_FC4.custom)
EIP is at remove_wait_queue+0x27/0x70
eax: f6cc6000   ebx: f61ffce0   ecx: 00000000   edx: d96eb034
esi: d96eb040   edi: 00000296   ebp: d96eb000   esp: f6cc7ed4
ds: 007b   es: 007b   ss: 0068
Process ntpd (pid: 2818, threadinfo=f6cc6000 task=f658ba60)
Stack: d96eb048 d96eb030 d96eb008 c017054d f61ffce0 00000080 00000007 00000019
       c0170a6d f6cc7f54 00000000 00000000 00000007 7fffffff f476d2b0 f476d2b4
       f476d2b8 f476d2a4 f476d2a8 f476d2ac f6cc6000 00000070 00000000 00000000
Call Trace:
 [<c017054d>] poll_freewait+0x2d/0x60
 [<c0170a6d>] do_select+0x31d/0x370
 [<c0170580>] __pollwait+0x0/0xd0
 [<c0170d44>] sys_select+0x244/0x3f0
 [<c0102ea5>] syscall_call+0x7/0xb
Code: 00 8d 76 00 83 ec 0c 89 1c 24 89 74 24 04 89 7c 24 08 9c 5f fa b8 00 e0 ff ff 21 e0 ff 40 14 8d 72 0c 8b 5a 0c 8b 4e 04 89 4b 04 <89> 19 c7 46 04 00 02 20 00 c7 42 0c 00 01 10 00 57 9d ff 48 14
 <6>note: ntpd[2818] exited with preempt_count 1


Expected Results:  should run fine

Additional info:

This may be a kernel issue or a memory issue.

How do I tell which it is?  I'd think if it was memory / hardware I'd see the problem in other programs.
Comment 1 Petr Raszyk 2006-01-05 07:44:07 EST
Created attachment 122813 [details]
ntp-4.2.0.a.20050816-2.src.rpm

Can you compile and install the *.src.rpm above ?
Running ntpd creates  /tmp/ntpd.PID  files (structured auto trace/debug).
Please, can you send me these files ?
Comment 2 Joe Acosta 2006-01-12 13:04:24 EST
I think one of the FC4  updates fixed this as it no longer seems to be
happening.  I'll have to check my logs again, but ntpd seems to be working okay
now.  

Note You need to log in before you can comment on or make changes to this bug.