Bug 166423 - vesa driver mode
Summary: vesa driver mode
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-20 21:09 UTC by Rahul Sundaram
Modified: 2014-03-17 02:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 21:32:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rahul Sundaram 2005-08-20 21:09:34 UTC
Description of problem:

We do not provide an easy way for the user currently to recover from a broken X
configuration other than system-config-display


Expected results:

A init script enhancement to provide a Windows like safe modem would be nice. A
potential implementation could be 

Press "F1"  to boot into safe mode which will boot into the Xorg Vesa driver
using the current configuration otherwise merely changing the driver only saving
for the current session


Additional info:

Such a implementation is not likely to work across all architectures and
displays according to mharris but I consider it worth a try if we push it in
rawhide quickly and ask for feedback to see how well it performs in the
development tree and enable it later on FC5 or a later relaase depending on
feedback.

Comment 1 Bill Nottingham 2005-10-03 21:32:42 UTC
Adding code to initscripts to edit the X config file seems rather impractical,
especially since with split X it may be likely that the vesa driver isn't even
installed.


Note You need to log in before you can comment on or make changes to this bug.