Bug 166426 - Review Request: grhino - Othello/Reversi game
Review Request: grhino - Othello/Reversi game
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
David Lawrence
http://hircus.org/fedora/grhino/
:
Depends On:
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2005-08-20 18:07 EDT by Michel Alexandre Salim
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-07 02:29:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2005-08-20 18:07:49 EDT
Spec Name or Url: http://hircus.org/fedora/grhino/grhino.spec
SRPM Name or Url: http://hircus.org/fedora/grhino/grhino-0.15.0-1.fc4.src.rpm
Description: 
GRhino, or Rhino its former name, is an Othello/Reversi game on Linux and other
UNIX-like systems as long as GNOME 2 libraries are installed. It is currently
under development and a new version is available occasionally.

What distinguish GRhino from most other Othello games is that GRhino will be
targeted for experienced Othello players. Strong AI is the main focus with some
additional good, useful features (like an endgame solver) is planned. The
ultimate target strength of the AI is that it should be able to beat the best
human player at the highest difficulty level. Beating Logistello (the strongest
program available) is not in the plan :)

Othello is a registered trademark of Tsukuda Original, licensed by Anjar Co.,
copyright 1973, 1990 Pressman Toy Corporation.
Comment 1 Aurelien Bompard 2005-09-02 15:52:45 EDT
Missing BuildRequires: libgnomeui-devel
Apart from that, it looks good.
Comment 2 Michel Alexandre Salim 2005-09-02 18:45:14 EDT
http://hircus.org/fedora/grhino/grhino.spec
http://hircus.org/fedora/grhino/grhino-0.15.0-2.fc4.src.rpm

- BuildRequires on libgnomeui-devel instead of libgnome-devel; the former
requires on the latter
- Updated description to mention that GRhino is GTP-compliant

Thanks for the review!
Comment 3 Aurelien Bompard 2005-09-03 04:51:55 EDT
Passed:
* RPM name is OK
* Source grhino-0.15.0.tar.gz is the same as upstream
* Builds fine in mock
* rpmlint of grhino looks OK
* File list of grhino looks OK
* Seems to work fine

Note You need to log in before you can comment on or make changes to this bug.