Bug 1664260 - Cannot get installplan after creating subscription on console
Summary: Cannot get installplan after creating subscription on console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Alec Merdler
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-08 09:19 UTC by shahan
Modified: 2019-06-04 10:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:49 UTC

Description shahan 2019-01-08 09:19:29 UTC
Description of problem:
 Cannot get installplan after creating subscription on console


Version-Release number of selected component (if applicable):
quay.io/openshift-release-dev/ocp-v4.0@sha256:82408fbb3dfc31e35679d9dea48c44d7baf6a2af52dd976c60022d446d1eb64e"
image id: 7f8e4a1588a21b4
installer verison: v0.9.1
cluster version: 4.0.0-9

How reproducible:
Always

Steps to Reproduce:
1. goto Catalog->Operator Management, under 'Enabled Operators' tab, subscribe one operator
2. goto Catalog->Operator Management, check 'InstallPlans' 
3. $ oc get ip -n hasha-pro1
NAME                                        CSV                           SOURCE         APPROVAL    APPROVED
install-amqstreams.v1.0.0.beta-q92rd        amqstreams.v1.0.0.beta        rh-operators   Automatic   false
install-marketplace-operator.v0.0.1-54f5l   marketplace-operator.v0.0.1   rh-operators   Automatic   false


Actual results:
2. There is no the ip created by subscription. it show "
No Install Plans Found". URL:https://$console-route/operatormanagement/ns/hasha-pro1/installplans

3. list the ip successfully

Expected results:
should get ip successfully

Additional info:

Comment 1 Alec Merdler 2019-01-16 17:18:45 UTC
https://github.com/openshift/console/pull/1094

Comment 3 shahan 2019-01-29 03:33:30 UTC
The install plan displays well in specific project scope.
$ git log 5070df1f11d481f36152c0218f209a085eed9d64 |grep '#1094'
    Merge pull request #1094 from alecmerdler/bugzilla-1664260
    Merge pull request #1094 from sman591/ui-updates

console commit: 5070df1f11d481f36152c0218f209a085eed9d64
Verified bug.

Comment 6 errata-xmlrpc 2019-06-04 10:41:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.