Bug 1664342 - RHV WEB-GUI sorts disk Snapshots rows alphabetically.
Summary: RHV WEB-GUI sorts disk Snapshots rows alphabetically.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.10
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.3.1
: 4.3.0
Assignee: Steven Rosenberg
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-08 14:16 UTC by Shivraj
Modified: 2019-05-08 12:39 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.3.1.1
Doc Type: Bug Fix
Doc Text:
The sorting order in the list of Disks in the Storage tab of the Administration Portal was sorted alphabetically by text values in the Creation Date, instead of by time stamp. In this release, the list is now sorted by the time stamp.
Clone Of:
Environment:
Last Closed: 2019-05-08 12:39:09 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:39:19 UTC
oVirt gerrit 97685 0 master MERGED webadmin: Fixed Snapshot Creation Date Sorting 2019-02-12 18:11:04 UTC

Description Shivraj 2019-01-08 14:16:10 UTC
Description of problem:

Disk snapshots pane under Storage tab displays all disk snapshots. If you try to sort it based on 'Creation Date' it sorts it based on Text of the date instead of actual timestamp.

Version-Release number of selected component (if applicable):

This issue was seen in RHV4.1.10 (rhevm-4.1.10.3-0.1.el7.noarch)

How reproducible:

1.  In RHV admin portal under Storage tab select a storage domain which has multiple snapshot disks. Having multiple snapshot disks is important to see the results.

2.  After selecting in sub-pane, there are multiple tabs. Go to Disk Snapshots.

3. On Disk Snapshots try to sort the list below using "Creation Date".

Actual results:

Unfortunately, the sorting goes by a text string (alphabetically) and not by timestamp which is very inconvenient.

Expected results:

The sorting should be done according to the date (timestamp) and not the text string.

Additional info:

- Wherever possible the sorting of the list should be done by type of the data e.g. as per timestamp if sorting by Creation date, integer number if sorting by Size.

Comment 4 Ryan Barry 2019-01-21 14:53:35 UTC
Re-targeting to 4.3.1 since it is missing a patch, an acked blocker flag, or both

Comment 6 RHV bug bot 2019-02-21 17:26:20 UTC
WARN: Bug status (ON_QA) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status (ON_QA) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 7 Petr Matyáš 2019-03-07 11:32:54 UTC
Verified on ovirt-engine-4.3.2-0.1.el7.noarch

Comment 9 errata-xmlrpc 2019-05-08 12:39:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.