Bug 1664506 - Using operator to install asb, the namespace,dc,clusterservicebroker should be same with 3.11
Summary: Using operator to install asb, the namespace,dc,clusterservicebroker should b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Erik Nelson
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-09 03:28 UTC by Zihan Tang
Modified: 2019-06-04 10:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:43 UTC

Description Zihan Tang 2019-01-09 03:28:57 UTC
Description of problem:
When using asb operator to install asb, 
the default namespace should be 'openshift-ansible-service-broker',
the default dc should be 'asb'
default route and service should be 'asb'

clusterservicebroker name should be 'ansible-service-broker'

Version-Release number of selected component (if applicable):
openshift-install v0.9.0
OLM version: 0.8.0
git commit: 67f26f5
automation-broker-operator: docker.io/automationbroker/automation-broker-operator:latest

How reproducible:
always

Steps to Reproduce:
1. install automation-broker operator and asb
  # oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/01-asb-catalogsource-configmap.yaml
  # oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/02-asb-catalogsource.yaml

# oc create namespace automation-broker
# oc create clusterrolebinding automation-broker-admin --clusterrole=admin --serviceaccount=automation-broker:automation-broker
# oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/03-asb-operatorgroup.yaml
# oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/04-asb-subscription.yaml
# oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/05-asb-cr.yaml


Actual results:
ASB created successfully. but the dc/route/clusterservicebroker name is 'automation-broker'

# oc get dc
NAME                REVISION   DESIRED   CURRENT   TRIGGERED BY
automation-broker   1          1         1         config

# oc get route
NAME                HOST/PORT                                                                  PATH      SERVICES   PORT        TERMINATION   WILDCARD
broker              broker-automation-broker.apps.zitang.devcluster.openshift.com                        broker     port-1338   reencrypt     None
broker-redirector   broker-redirector-automation-broker.apps.zitang.devcluster.openshift.com             broker     port-1337                 None
# oc get service
NAME      TYPE        CLUSTER-IP       EXTERNAL-IP   PORT(S)             AGE
broker    ClusterIP   172.30.232.241   <none>        1337/TCP,1338/TCP   17h

# oc get clusterservicebroker
NAME                      URL                                                                                         STATUS    AGE
automation-broker         https://broker.automation-broker.svc:1338/osb/                                              Ready     17h


Expected results:
1. should use 'openshift-ansible-service-broker' namespace by default,
2. default dc, route and service name should be 'asb'
3. clusterservicebroker name should be 'ansible-service-broker

Additional info:

Comment 1 Zihan Tang 2019-01-09 07:13:05 UTC
In v3.11, if enable dashboard_url, 
the name of containers and services are: 
# oc get pod asb-1-scrs8  -o jsonpath="{.spec.containers[*].name}"
dashboard-redirector asb

# oc get route
NAME       HOST/PORT                                                                PATH      SERVICES   PORT      TERMINATION   WILDCARD
asb-1338   asb-1338-openshift-ansible-service-broker.apps.0109-ash.qe.rhcloud.com             asb        1338      reencrypt     None
dr-1337    dr-1337-openshift-ansible-service-broker.apps.0109-ash.qe.rhcloud.com              asb        1337                    None

# oc get service
NAME      TYPE        CLUSTER-IP      EXTERNAL-IP   PORT(S)             AGE
asb       ClusterIP   172.30.95.240   <none>        1338/TCP,1337/TCP   1h

in 4.0, it should be the same with 3.11 if enable dashboard_url.

Comment 2 Erik Nelson 2019-01-15 14:27:06 UTC
Requires fixes in a couple repos -

ASB operator PR: https://github.com/openshift/ansible-service-broker/pull/1164
Catbrokers PR: https://github.com/fusor/catbrokers4/pull/7

Comment 3 Erik Nelson 2019-01-15 20:24:05 UTC
I've pushed an updated operator image that should get installed via the catbrokers script. Please let me know if that satisfies requirements.

Comment 4 Zihan Tang 2019-01-16 07:46:17 UTC
I tried with the latest catbrokers script and operator image, the name of dc, pod, route, service are the same with 3.11.

but the container names are:   [broker-redirector broker]
in v3.11, they are : [dashboard-redirector asb]

it's better to keep it the same.

Comment 5 Erik Nelson 2019-01-16 13:45:01 UTC
Updated container names PR: https://github.com/openshift/ansible-service-broker/pull/1165, I've also pushed a new image.

If you need any other changes, please batch the requested changes in one request so we can cut down on back and forth.

Comment 6 Zihan Tang 2019-01-17 07:18:23 UTC
Verified 
image: docker.io/ansibleplaybookbundle/origin-ansible-service-broker:canary
container name in asb dc is [dashboard-redirector asb]

Comment 9 errata-xmlrpc 2019-06-04 10:41:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.