Bug 1664559 - [marketplace] operators can be enabled multipule times until it is subscribed to the “global-operators” Operator Group through marketplace UI
Summary: [marketplace] operators can be enabled multipule times until it is subscribed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.1.0
Assignee: lgallett
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-09 06:54 UTC by Fan Jia
Modified: 2019-06-04 10:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:43 UTC

Description Fan Jia 2019-01-09 06:54:36 UTC
Description of problem:
If the cluster has several Operator Group like “test1”, “test2” and the ordinary  “global-operators”The operators on the Marketplace UI like “etcd” can be enabled to Operator Group “test1”, and enabled to “test2”,then enabled to “global-operators”. Then the “enabled” label will add to the etcd operator’s tile and the enable button will be gray on the detail page. 
If enable “etcd” to OG “global-operators” at first, then the the “enabled” label will add to the etcd operator’s tile and the enable button will be gray on the detail page. The operator “etcd” won’t be enabled to OG “test1”, “test2”. 

Version-Release number of selected component (if applicable):
cluster version: 4.0.0-0.alpha-2019-01-06-163602 
MARKETPLECE: latest

How reproducible:
Always

Steps to Reproduce:
1. enable the operator “etcd” to OG “test1” through Marketplace UI

Actual results:
1) after step 1, the operator “etcd” can be enabled to other OG through Marketplace UI

Expected results:
1)after step 1, the operator “etcd” can’t be enabled to other OG through Marketplace UI

Additional info:
You can still click the subscribe button on the detail page of operator "etcd" to OG "test1" even it has already been subscribed to OG "test1". And nothing will happen, the page won't prompt that the operator has already been subscribeb to OG "test1".

Comment 1 Fan Jia 2019-01-09 07:52:48 UTC
operator group example test1:
apiVersion: operators.coreos.com/v1alpha2
kind: OperatorGroup
metadata:
  name: test1
  namespace: test1
  selfLink: >-
    /apis/operators.coreos.com/v1alpha2/namespaces/openshift-operators/operatorgroups/test1
status:
  namespaces:
    - ''

Comment 2 aravindh 2019-01-24 19:20:30 UTC
We don't support multiple OperatorGroups for 4.0, so we don't support enabling operators to multiple OperatorGroups through Operator Hub UI. Given that this is not a bug.

Comment 3 Fan Jia 2019-02-28 07:18:51 UTC
The latest version updates the install way of the "operators" by `Install Mode`, So it is not a problem anymore.

Comment 4 Zhang Cheng 2019-02-28 07:34:35 UTC
Jia,

Please update bug status if it is OKay for you base on current implement and design. Thx.

Comment 7 errata-xmlrpc 2019-06-04 10:41:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.