Bug 166469 - xmms freaks out on Double size
xmms freaks out on Double size
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-22 02:15 EDT by Mike Perry
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 09:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Perry 2005-08-22 02:15:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When you try to doublesize xmms (clicking the D next to the song duration) under either the BlueCruve theme or no theme, either the window becomes garbled or it crashes.

Version-Release number of selected component (if applicable):
xmms-1.2.10-16

How reproducible:
Always

Steps to Reproduce:
1. Start xmms
2. Click D
3. Kaboom
  

Actual Results:  Kaboom.

Expected Results:  Double sized window.

Additional info:
Comment 1 John (J5) Palmieri 2005-08-22 11:42:19 EDT
xmms has moved to extras in fc4
Comment 2 Matthias Saou 2005-08-22 11:50:49 EDT
This looks quite similar to this existing bug report found upstream :

http://bugs.xmms.org/show_bug.cgi?id=1907

Could you confirm that the workaround works for you?
Comment 3 Matthias Saou 2005-08-26 09:34:12 EDT
This bug is composite/gtk1 related anyway, so I'll close WONTFIX and copy the
quote from the above bug report (already quoted from elsewhere) :

Q: After enabling the Composite extension, XMMS refuses to start!
A: True, the gtk 1.x gdk part does not work too good with the Composite
extension and i do not know a patch to correct that.
Furthermore - any gtk 1.x application won't work too good with the xcompmgr,
because it will allways appear additive composed (if you place the gtk 1.x
window over a white background, you won't see anything
At least for XMMS, the Beep Media Player (xmms gtk 2.x port) is a good solution.
It does a very good job and gtk 2.x looks much better anyway =)

Development time is much better spent on beep-media-player or on the new xmms2.
For now, people who want to use the double size feature of xmms should disable
the composite extension in xorg.conf.
If ever someone comes up with a patch for the issue, I'll gladly include it in
the Extras xmms package.

Note You need to log in before you can comment on or make changes to this bug.