Bug 166475 - RFE: Update Test::More
RFE: Update Test::More
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-22 05:01 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 06:24:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-08-22 05:01:11 EDT
Description of problem:
The Test::More module (version 0.47, probably from the Test::Simple 0.47
distribution) being shipped with FC4's perl is too old to be usable for building
some newer perl-dists/modules, because newer perl dists start to depend on newer
of Test::More rsp. Test::Simple.

Version-Release number of selected component (if applicable):
perl-5.8.6-15

I'd propose to:
1. Update Test::Simple for FC4 (Current is 0.60)
2. To split out Test::Simple into a separate perl-Test-Simple package for FC5

ATM, this issue prevents me from submitting perl-packages to FE, and having to
resort to either
* submitting older versions of perl dists.
or
* switch off perl packages' test suites (Test::More is primarily used for tests
when building perl packages)
Comment 1 Ville Skyttä 2005-08-22 13:07:37 EDT
Splits like that are a PITA to maintain and prune.  Somewhat ugly, but IMO 
considerable workaround: 
 
%check 
if %{__perl} -e 'use Test::Simple 0.60' ; then 
    make test 
fi 
Comment 2 Warren Togami 2005-09-04 06:24:30 EDT
Sorry I agree with Ville here.  We can't add this to all older distributions and
it really isn't that important.

Note You need to log in before you can comment on or make changes to this bug.