Bug 1664816 - Fedora 28 - No Sound Through HDMI
Summary: Fedora 28 - No Sound Through HDMI
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-09 17:50 UTC by jogoscontapsa
Modified: 2019-05-28 23:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-28 23:46:19 UTC


Attachments (Terms of Use)

Description jogoscontapsa 2019-01-09 17:50:49 UTC
Description of problem:

Using Fedora 28 I cant send sound through HDMI. The video is displayed perfectly, everything from the visual stand point works great, but there is no sound coming through. Note that this problem first appeared a few months ago, but after reinstalling pulseaudio everything worked great. 2 weeks ago when i tried to watch a movie on my computer using HDMI to send it to the TV the sound didn't work again... 

Using "pulseaudio Volume Control" Graphical Tool:
-> On the output devices I only see my Built-in audio analog Stereo and not the HDMI option. Going into the "Configuration" tab, I can see the "HDA Nvidia" option but is set to "OFF", trying to change this is to no avail due to every-single option showing an "(Unpluged)" indication at the end. 


The output of "aplay -l":

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

System Kernel version: 4.19.13-200.fc28.x86_64
I am using only this GPU: GeForce GTX 960
I am using NVidia proprietary drivers Version: 415.25



Version-Release number of selected component (if applicable):

pulseaudio-12.2-1.fc28.x86_64
alsa-plugins-pulseaudio-1.1.6-3.fc28.x86_64

How reproducible:
Every Time.

Steps to Reproduce:
1. Connect HDMI to TV.
2  Play something with sound.

Actual results:
No Sound comes from the TV connected through HDMI. Using the system built-in Volume Control can't change the output device for sound.

Expected results:
TV connected through HDMI to reproduce sound from the system.

Comment 1 Ben Cotton 2019-05-02 19:47:53 UTC
This message is a reminder that Fedora 28 is nearing its end of life.
On 2019-May-28 Fedora will stop maintaining and issuing updates for
Fedora 28. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora 'version' of '28'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 28 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 2 Ben Cotton 2019-05-28 23:46:19 UTC
Fedora 28 changed to end-of-life (EOL) status on 2019-05-28. Fedora 28 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.