Bug 166486 - evolution keeps hanging and must be killed (bt attached)
evolution keeps hanging and must be killed (bt attached)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-08-22 08:24 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 15:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb backtrace (11.21 KB, text/plain)
2005-08-22 08:26 EDT, Need Real Name
no flags Details
attaching to hung process (5.49 KB, text/plain)
2005-08-23 03:26 EDT, Need Real Name
no flags Details
attaching to hung process, hang 2 (5.61 KB, text/plain)
2005-08-23 04:05 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2005-08-22 08:24:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Epiphany/1.6.5

Description of problem:
Evolution keeps crashing for no apparent reason.
Tenth time today.

Using Evolution talking to an Exchange server, so package may be wrong.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. It crashes by itself.

Additional info:
Comment 1 Need Real Name 2005-08-22 08:26:38 EDT
Created attachment 117966 [details]
gdb backtrace
Comment 2 Need Real Name 2005-08-22 09:07:32 EDT
Sorry, evolution is not crashing, it's hanging and I have to kill it.
Comment 3 Dave Malcolm 2005-08-22 14:52:13 EDT
Thanks for this report.

Please can you do an "rpm -q evolution evolution-data-server
evolution-connector" and identify the versions in use.

Does this problem occur if you run evolution outside of gdb?

The backtrace you attached looks like it was generated by starting evolution
within gdb.  Unfortunately, this always hangs in the initialisation of gnome_vfs
inside the call to seteuid; I think it's a bad interraction between gdb and that
function call.  So that stops the main GUI thread: thread 1 in your backtrace,
and the UI will hang.  This happened when you right-clicked on an attachment.

If evolution still hangs when run outside of gdb, then it's something else, and
will need tracking down.  You appear to have evolution-debuginfo installed;
please can you also install evolution-data-server-debuginfo and
evolution-connector-debuginfo.  Then please can you generate a backtrace by
starting evolution outside of gdb, and try to reproduce the hang.  Once
evolution has hung, please can you find the process ID of the evolution process
and attach gdb to it ("gdb attach THE_PID").  Then do a "t a a bt" and we'll see
what it's doing.

Alternatively, if it's a crash when run outside of gdb (and a hang inside due to
the above cause), then start evolution outside of gdb (with the debuginfo
packages installed) and try to crash it.  If/when it crashes, bug-buddy should
launch and give you a backtrace of all threads, please save it and attach it to
this bug.

(In thread 3 or your backtrace, evolution is waiting for more data from the
evolution-exchange-storage backend.  So it may be that that process has hung,
though that's a hunch at this stage).

Thanks
Comment 4 Need Real Name 2005-08-22 15:03:30 EDT
The hang occurs outside of gdb too. The reason I ran evolution from gdb because
a "pgrep evolution" shows more than one process, four I think. Which shall I
attach to?

The box is fully yummed, but I'll get versions for here tomorrow.

Thanks.
Comment 5 Dave Malcolm 2005-08-22 15:07:01 EDT
Start by attaching to the "evolution" process: "ps ax | grep evolution" will
show the details.

Please can you also specify the exact packages you're running (it's much easier
when looking back over past bugs to know which versions we were dealing with). 
Thanks.
Comment 6 Need Real Name 2005-08-23 02:50:46 EDT
yum says there is no evolution-connector-debuginfo.
evolution-data-server-debuginfo is already installed.

# rpm -q evolution evolution-data-server
evolution-2.2.3-2.fc4
evolution-data-server-1.2.3-2.fc4
Comment 7 Need Real Name 2005-08-23 03:26:33 EDT
Created attachment 117993 [details]
attaching to hung process

"ps ax | grep evolution" gives me the same as "pgrep evolution".
Attached is the bt for the main evolution process.
Comment 8 Need Real Name 2005-08-23 04:05:33 EDT
Created attachment 117994 [details]
attaching to hung process, hang 2

Another bt, this one looks a bit different (no "corrupt stack?" warning).
Comment 9 Need Real Name 2005-08-23 06:14:11 EDT
Aha! Looks like the problem was a dhcp server giving out the wrong ip address.
Two computers with the same ip. Fixed now, problem seems to have gone away.
Comment 10 Dave Malcolm 2005-08-23 15:07:16 EDT
OK - so this was causing a hang (rather than crash)?

Good to hear that it's working for you now.  In theory we could make Evolution
more robust against this kind of network problem, but it's not a priority.  With
that in mind, I'm going to close this one as WONTFIX.  Feel free to reopen it if
the hang problem recurs.  Thanks for all of your feedback.
Comment 11 Need Real Name 2005-08-24 15:18:38 EDT
Just to confirm, it was a hang, not a crash.
Comment 12 Dave Malcolm 2005-08-24 15:25:01 EDT
Thanks

Note You need to log in before you can comment on or make changes to this bug.