Bug 166489 - PyGTK2 needs PyCairo to compile some of its bindings
Summary: PyGTK2 needs PyCairo to compile some of its bindings
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-22 13:30 UTC by Jacob Kroon
Modified: 2013-03-13 04:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-22 17:12:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jacob Kroon 2005-08-22 13:30:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050818 Fedora/1.1-0.2.7.deerpark.alpha2.1 Firefox/1.0+

Description of problem:
PyGTK2 provides bindings for using Gtk/Pango together with Cairo, but these
libraries aren't compiled during rpmbuild because they require that PyCairo is
installed. So I'd like to make a wish that pycairo gets included into Core,
so that these bindings get shipped with the regular PyGTK2 rpm.

Version-Release number of selected component (if applicable):
pygtk2-2.7.3-2

How reproducible:
Always

Steps to Reproduce:
Running any of the pango-cairo examples will fail, since it tries to "import pangocairo" which isnt shipped currently with PyGTK2


Additional info:

Comment 1 John (J5) Palmieri 2005-08-22 17:12:14 UTC
As I was informed PyCairo might be changing its APIs at some point.  Also policy
is that we don't pull things into core unless something in core need it.  I
would suggest helping get pycairo into Extras if it is not there already.  A
pygtk2-extras can also be added which would build off the same sources as the
pygtk2 package in Core but only pull in the modules that were not built in the
Core package. 

Comment 2 Jacob Kroon 2005-09-04 20:46:00 UTC
Ok that makes sense. I don't think I am the right person for
managing the rpm in extras, but I'll bring the proposal out somehow.
As a sidenote PyCairo 1.0.0 has been released now.

Comment 3 Jacob Kroon 2005-09-06 13:53:55 UTC
I've sent a proposal for PyCairo together with spec/SRPM to fedora-extras:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167621


Note You need to log in before you can comment on or make changes to this bug.