Bug 1664911 - Update federation operator to the right version for OCP 4.0
Summary: Update federation operator to the right version for OCP 4.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Paul Morie
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-10 02:18 UTC by Qin Ping
Modified: 2019-06-04 10:41 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:48 UTC

Description Qin Ping 2019-01-10 02:18:23 UTC
Description of problem:
Deploy federation control plane with OLM, the federation control plane can be deployed successfully, but the version is federationv2.v0.0.2. It's not the version plans to release in OCP4.0

Version-Release number of selected component (if applicable):
$ oc exec olm-operator-5f7dcdcd8f-ttn7t -- olm -version
OLM version: 0.8.0
git commit: 75e95a0


How reproducible:
Always

Steps to Reproduce:
1. Create a subscription for federation v2 in the web console.
2. Check Federation V2 control plane Pod is created successfully.
3. Check the control plane version.

Actual results:
Image: quay.io/kubernetes-multicluster/federation-v2:v0.0.2-rc.1

Expected results:


Additional info:
]$ oc logs federation-controller-manager-5d796cc445-882fl
I0109 08:55:47.218753       1 main.go:77] Version: {Version:v0.0.1-alpha.0 GitCommit:unknown G

Comment 1 Paul Morie 2019-02-14 19:27:09 UTC
This is in-progress now. I've updated the manifests in the openshift repo, which you can see here:

https://github.com/openshift/federation-v2-operator/tree/master/manifests/federation-v2

However, these need to be updated in the community-operators repo still, and I've found a couple things that need tweaking for that happens. Expect this to land in the next few days.

Comment 2 Paul Morie 2019-02-19 23:11:11 UTC
To temporarily unblock QE, I've added instructions in the README for how to test a local version:

https://github.com/openshift/federation-v2-operator#developing

I will work to update the manifests in the community operators repo as a next step, but for now you should be able to follow the instructions to test.

Comment 3 Paul Morie 2019-02-19 23:12:19 UTC
Putting into ON_QA; I'll expect it to come back to ASSIGNED until I finish updating the manifests in the community-operators repo but this should at least unblock testing.

Comment 5 Paul Morie 2019-02-21 19:31:26 UTC
I've made a PR to update the OLM manifests in the community-operators repo:

https://github.com/operator-framework/community-operators/pull/88

...will comment and put to MODIFIED when that merges.

Comment 7 Qin Ping 2019-03-19 05:38:22 UTC
Verified with:
4.0.0-0.nightly-2019-03-15-063749

kubefed2 version: version.Info{Version:"0.0.6", GitCommit:"de6a0a909418f5ddf2d04d232b0ca55aa9cffb49", GitTreeState:"clean", BuildDate:"2019-03-14T00:43:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}

Federation v2 controller-manager version: version.Info{Version:"0.0.6", GitCommit:"de6a0a909418f5ddf2d04d232b0ca55aa9cffb49", GitTreeState:"clean", BuildDate:"2019-03-14T00:43:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}

Comment 9 errata-xmlrpc 2019-06-04 10:41:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.