Bug 1664981 - nagios-plugins-ntp contains old perl script instead of compiled binary check_ntp
Summary: nagios-plugins-ntp contains old perl script instead of compiled binary check_ntp
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Stephen John Smoogen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1710544 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-10 08:06 UTC by Ziegler Karel
Modified: 2019-09-14 04:05 UTC (History)
9 users (show)

Fixed In Version: nagios-plugins-2.2.1-17.20190829gitfb792ff.fc29 nagios-plugins-2.2.1-17.20190829gitfb792ff.el7 nagios-plugins-2.2.1-17.20190829gitfb792ff.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-11 21:18:39 UTC


Attachments (Terms of Use)

Description Ziegler Karel 2019-01-10 08:06:44 UTC
Description of problem:

nagios-plugins-ntp contains old perl script instead of compiled binary check_ntp.

Source tree on https://github.com/nagios-plugins/nagios-plugins contains these to checks in two directories - old perl script in plugins-scripts and the c-code in plugins. So there is the name conflict and probably during rpm building the compiled binary version of check_ntp is than overwritten by the perl script.

Please, remove the perl version from the source tree or rename the perl version or somehow correct the logic of merging (name conflicts) checks/files from those directories.


Version-Release number of selected component (if applicable):

BAD 2.2.1-16.20180725git3429dad.el7 (contains perl version)
BAD 2.2.1-15.20180725git3429dad.el7 (contains perl version)
OK  2.2.1-9git5c7eb5b9.el7          (contains binary version)


How reproducible:

Update packages to latest available version.


Actual results:

# /usr/lib64/nagios/plugins/check_ntp -h
check_ntp v2.2.1.git (nagios-plugins 2.2.1)
The nagios plugins come with ABSOLUTELY NO WARRANTY. You may redistribute
copies of the plugins under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.
Copyright (c) 2003 Bo Kersey/Karl DeBisschop

Usage: check_ntp -H <host> [-46] [-O] [-w <warn>] [-c <crit>] [-j <warn>] [-k <crit>] [-v verbose]
...

# file /usr/lib64/nagios/pluginscheck_ntp
check_ntp: Perl script, ASCII text executable


Expected results:

# /usr/lib64/nagios/plugins/check_ntp -h
check_ntp v2.2.1.git (nagios-plugins 2.2.1)
Copyright (c) 2006 Sean Finney
Copyright (c) 2006-2014 Nagios Plugin Development Team
        <devel@nagios-plugins.org>

This plugin checks the selected ntp server


WARNING: check_ntp is deprecated. Please use check_ntp_peer or
check_ntp_time instead.

Usage:
 check_ntp -H <host> [-w <warn>] [-c <crit>] [-j <warn>] [-k <crit>] [-4|-6] [-v verbose]
...

# file /usr/lib64/nagios/plugins/check_ntp
/usr/lib64/nagios/plugins/check_ntp: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=077438a2982921aa6b395ebfaf35976f533e92c3, stripped


Additional info:

Source tree on https://github.com/monitoring-plugins/monitoring-plugins does not contain the perl script check_ntp.pl in plugins-scripts directory.

Comment 1 Ziegler Karel 2019-04-07 21:32:11 UTC
Now it's also broken in the new version of nagios-plugins 2.2.1-15.20180725git3429dad.el6 in EPEL 6, released yesterday.

Comment 2 Ziegler Karel 2019-04-07 21:39:14 UTC
The problem is in that the package nagios-plugins-ntp doesn't contain binary check_ntp but the perl script, which is the same like the one from the package nagios-plugins-ntp-perl (check_ntp.pl).

Problem started with nagios-plugins version 2.2.1-15.20180725git3429dad for both EL6 and EL7.

Comment 3 Stephen John Smoogen 2019-08-29 21:04:32 UTC
OK my apologies for the delay on this. I have found that the upstream makefile installing the wrong plugin and I thought I fixed this twice before but missed it.

Comment 4 Stephen John Smoogen 2019-08-29 21:36:24 UTC
*** Bug 1710544 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2019-08-29 21:51:13 UTC
FEDORA-EPEL-2019-9b63c08c0f has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9b63c08c0f

Comment 6 Fedora Update System 2019-08-29 22:04:09 UTC
FEDORA-EPEL-2019-22c97df420 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-22c97df420

Comment 7 Fedora Update System 2019-08-30 16:07:41 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-22c97df420

Comment 8 Fedora Update System 2019-08-30 16:07:43 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9b63c08c0f

Comment 9 Fedora Update System 2019-09-03 13:46:10 UTC
FEDORA-2019-fef2650216 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-fef2650216

Comment 10 Fedora Update System 2019-09-04 05:02:39 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-fef2650216

Comment 11 Fedora Update System 2019-09-11 21:18:39 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-09-14 00:40:36 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-09-14 04:05:13 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.