Bug 1664984 - No image-registry operator manifest in 4.0.0-0.nightly-2019-01-10-005204 payload
Summary: No image-registry operator manifest in 4.0.0-0.nightly-2019-01-10-005204 payload
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.1.0
Assignee: Tim Bielawa
QA Contact: Wei Sun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-10 08:18 UTC by Wenjing Zheng
Modified: 2019-06-04 10:41 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:48 UTC

Description Wenjing Zheng 2019-01-10 08:18:16 UTC
Description of problem:
There is no image-registry manifest in 4.0.0-0.nightly-2019-01-08-152529 payload

Version-Release number of selected component (if applicable):
registry.svc.ci.openshift.org/ocp/release@sha256:de71c95dbce7a6e284e719a86140a7914ce2e82a2db1607810d3300d989f8d4c

How reproducible:
always

Steps to Reproduce:
1.oc adm release extract registry.svc.ci.openshift.org/ocp/release@sha256:de71c95dbce7a6e284e719a86140a7914ce2e82a2db1607810d3300d989f8d4c --to=.
2.
3.

Actual results:
No image-registry manifest.

Expected results:
Should have

Additional info:

Comment 1 Wenjing Zheng 2019-01-11 05:55:10 UTC
If no image-registry operator manifest, internal image-registry cannot be setup. Build won't succeed for pushing built image to.

Comment 3 W. Trevor King 2019-01-11 17:24:07 UTC
Who's in charge of OCP builds?  I don't think it's Alex or me.  Do we have a better Component for OCP build issues, since this isn't an installer issue?

Comment 4 W. Trevor King 2019-01-11 17:50:10 UTC
Tim Bielawa suggests the "Release" component for issues with the OCP update payloads.  I'm not authorized to update this bug myself, but maybe you can fix the Component field, Wenjing?

Comment 7 Wenjing Zheng 2019-01-14 02:32:47 UTC
Verified with 4.0.0-0.nightly-2019-01-12-000105 as below:
$ oc adm release extract --from=registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-01-12-000105 --to=.
$ ls | grep registry
0000_70_cluster-image-registry-operator_00-crd.yaml
0000_70_cluster-image-registry-operator_01-namespace.yaml
0000_70_cluster-image-registry-operator_01-openshift-config-managed-namespace.yaml
0000_70_cluster-image-registry-operator_01-openshift-config-namespace.yaml
0000_70_cluster-image-registry-operator_02-rbac.yaml
0000_70_cluster-image-registry-operator_03-sa.yaml
0000_70_cluster-image-registry-operator_04-operator.yaml
0000_70_cluster-image-registry-operator_05-ca-config.yaml
0000_70_cluster-image-registry-operator_06-ca-rbac.yaml
0000_70_cluster-image-registry-operator_07-ca-serviceaccount.yaml

Comment 10 errata-xmlrpc 2019-06-04 10:41:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.