Bug 1665 - /dev/zero has incorrect permissions
/dev/zero has incorrect permissions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dev (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-22 04:25 EST by jmegq
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-23 15:13:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmegq 1999-03-22 04:25:33 EST
/dev/zero should be world writable, but is not.
This is true of the Rawhide and Starbuck releases as well
as the 5.2 release, and presumably other releases.

The manpage for /dev/null and /dev/zero ("man null") say
that both devices should be world-writable, but only
/dev/null is. (/dev/zero is owner and group writable only).

Strangely, MAKEDEV seems to want to make both devices 0666,
but I haven't verified that it does so.

The problem shows itself with JDK1.2pre-v1:
JDK1.2 uses /dev/zero internally to throw stuff away, and
expects it to be world-writable; I imagine this may be
confusing some people who are trying to use it.

e.g. (on starbuck):
    % setenv THREADS_FLAG green
    % java -Djava.compiler= -version
    devzero: Permission denied

Thanks,
//James//
Comment 1 David Lawrence 1999-03-23 14:10:59 EST
I have verified this to be true in the test lab. It is being assigned
to a developer.
Comment 2 Michael K. Johnson 1999-03-23 15:13:59 EST
This was originally changed because someone voiced a security-related
concern.  That concern (that /dev/zero does not erase the buffer
passed to it) is not a legitimate concern and while programs really
should use /dev/null to throw things away, I'll change the dev
package to make /dev/zero world writable in dev-2.6.4

Note You need to log in before you can comment on or make changes to this bug.