Bug 1665018 - All messages for CVO stauts of cluster-image-registry operator should start with a capital letter
Summary: All messages for CVO stauts of cluster-image-registry operator should start w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Corey Daley
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-10 09:49 UTC by XiuJuan Wang
Modified: 2019-06-04 10:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:48 UTC

Description XiuJuan Wang 2019-01-10 09:49:51 UTC
Description of problem:
All messages for CVO stauts of cluster-image-registry operator should start with a capital letter

Version-Release number of selected component (if applicable):

oc get clusterversion 
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-9   True        False         3h        Cluster version is 4.0.0-9
How reproducible:
always

Steps to Reproduce:
1.Check clusteroperator cluster-image-registry-operator
2.
3.

Actual results:
All messages don't start with a capital letter.

 #oc describe clusteroperator cluster-image-registry-operator                                                                                        dhcp-140-96.nay.redhat.com: Thu Jan 10 17:24:34 2019

Name:         cluster-image-registry-operator
Namespace:
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-01-10T08:32:47Z
  Generation:          1
  Resource Version:    134100
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/cluster-image-registry-operator
  UID:                 4f5ffaa3-14b2-11e9-8806-02b62a8ceef6
Spec:
Status:
  Conditions:
    Last Transition Time:  2019-01-10T09:19:43Z
    Message:               deployment has minimum availability
    Status:                True
    Type:                  Available
    Last Transition Time:  2019-01-10T09:19:43Z
    Message:               everything is ready
    Status:                False
    Type:                  Progressing
    Last Transition Time:  2019-01-10T08:32:50Z
    Status:                False
    Type:                  Failing
  Extension:               <nil>
  Version:                 2e125da-dirty
Events:                    <none>


Expected results:
All messages for CVO stauts of cluster-image-registry operator should start with a capital letter
It's better to make version of cluster-image-registry more professional

Additional info:

Comment 1 Corey Daley 2019-01-10 16:11:11 UTC
Fix is included in pending pull request: https://github.com/openshift/cluster-image-registry-operator/pull/147

Comment 2 Adam Kaplan 2019-02-26 14:49:01 UTC
PR has merged and is most likely in QA

Comment 3 XiuJuan Wang 2019-02-27 08:32:20 UTC
Conditions:
    Last Transition Time:  2019-02-26T01:07:23Z
    Message:               Deployment has minimum availability
    Status:                True
    Type:                  Available
    Last Transition Time:  2019-02-26T01:07:23Z
    Message:               Everything is ready
    Status:                False
    Type:                  Progressing
    Last Transition Time:  2019-02-26T01:06:23Z
    Status:                False
    Type:                  Failing
  Extension:               <nil>
  Related Objects:         <nil>
  Versions:
    Name:     operator
    Version:  v4.0.0-0.185.0.0-dirty

Verified with 
$oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE  
version   4.0.0-0.nightly-2019-02-26-054336   True        False         5h27m

Comment 6 errata-xmlrpc 2019-06-04 10:41:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.