Bug 1665021 - [marketplace] Can’t delete operatorsource cr and catalogsourceconfig cr after deleted the subscription/csv of marketplace operator
Summary: [marketplace] Can’t delete operatorsource cr and catalogsourceconfig cr after...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Kevin Rizza
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-10 09:57 UTC by Fan Jia
Modified: 2019-06-04 10:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:48 UTC

Comment 1 aravindh 2019-01-10 18:53:27 UTC
FYI, the subscription has no connection with the OperatorSource or CatalogSourceConfig. Moreover are you sure that your cluster is not flaking at this point? I have noticed similar issues and it usually happens when my cluster is flaking.

Comment 2 Fan Jia 2019-01-11 02:06:49 UTC
(In reply to aravindh from comment #1)
> FYI, the subscription has no connection with the OperatorSource or
> CatalogSourceConfig. Moreover are you sure that your cluster is not flaking
> at this point? I have noticed similar issues and it usually happens when my
> cluster is flaking.

The cluster is ok. "delete the subscription" in the description means "delete the marketplace-operator".

Comment 3 Kevin Rizza 2019-01-17 13:40:48 UTC
This is expected behavior. The marketplace operator adds finalizers to those custom resources as soon as they begin the reconciliation process. Those finalizers block the crs from being deleted until our operator is able to reconcile against the deletion phase. Then the operator will remove the finalizer and the cr will be garbage collected. So there should be no action here.

Comment 4 Fan Jia 2019-01-21 01:50:21 UTC
change the stauts to verified by this is the expected behavior.

Comment 7 errata-xmlrpc 2019-06-04 10:41:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.