Bug 1665051 - ipa-adtrust-install does not list service records for manual addition to DNS zone
Summary: ipa-adtrust-install does not list service records for manual addition to DNS ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: ipa
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: IPA Maintainers
QA Contact: ipa-qe
Lucie Maňásková
URL:
Whiteboard:
Depends On: 1683261
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-10 12:02 UTC by Sergey Orlov
Modified: 2020-08-17 15:19 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
.Information about required DNS records is now displayed when enabling support for AD trust in IdM Previously, when enabling support for Active Directory (AD) trust in Red Hat Enterprise Linux Identity Management (IdM) installation with external DNS management, no information about required DNS records was displayed. Entering the `ipa dns-update-system-records --dry-run` command manually was necesary to obtain a list of all DNS records required by IdM. With this update, the `ipa-adtrust-install` command correctly lists the DNS service records for manual addition to the DNS zone.
Clone Of:
Environment:
Last Closed: 2020-04-28 15:43:29 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Output of ipa-server-install (7.67 KB, text/plain)
2019-01-30 11:01 UTC, Sergey Orlov
no flags Details
Output of first run of ipa-adtrust-install (2.89 KB, text/plain)
2019-01-30 11:01 UTC, Sergey Orlov
no flags Details
Output of second run of ipa-adtrust-install (3.83 KB, text/plain)
2019-01-30 11:02 UTC, Sergey Orlov
no flags Details
Log file of ipa-server-install and both runs of ipa-adtrust-install (3.73 MB, text/plain)
2019-01-30 11:03 UTC, Sergey Orlov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Fedora Pagure freeipa issue 8192 0 None None None 2020-02-11 16:16:22 UTC
Red Hat Product Errata RHEA-2020:1640 0 None None None 2020-04-28 15:43:47 UTC

Description Sergey Orlov 2019-01-10 12:02:11 UTC
Description of problem:
When executing ipa-adtrust-install on IPA server without configured DNS, there should be list of service records in command output which user should manually add to DNS zone. Actually this list is empty. 


Version-Release number of selected component (if applicable):
ipa-server-trust-ad-4.7.1-7.module+el8+2555+b334d87b.x86_64

How reproducible:
Always

Steps to Reproduce:
1. dnf module enable -y idm:DL1/dns
2. dnf install -y ipa-server ipa-server-trust-ad 
3. ipa-server-install -p Secret123 -a Secret123 -U -n master.test.ipa -r TEST.IPA
4. ipa-adtrust-install -a Secret123 -U

Actual results:
...
  [17/23]: adding special DNS service records
DNS management was not enabled at install time.
Add the following service records to your DNS server for DNS zone master.test.ipa: 
  [18/23]: restarting Directory Server to take MS PAC and LDAP plugins changes into account
...

Expected results:
...
  [17/23]: adding special DNS service records
DNS management was not enabled at install time.
Add the following service records to your DNS server for DNS zone master.test.ipa: 
_ldap._tcp.Default-First-Site-Name._sites.dc._msdcs.master.test.ipa. 86400 IN SRV 0 100 389 host-8-253-10.host.centralci.eng.rdu2.redhat.com.
_ldap._tcp.dc._msdcs.master.test.ipa. 86400 IN SRV 0 100 389 host-8-253-10.host.centralci.eng.rdu2.redhat.com.
_kerberos._tcp.Default-First-Site-Name._sites.dc._msdcs.master.test.ipa. 86400 IN SRV 0 100 88 host-8-253-10.host.centralci.eng.rdu2.redhat.com.
_kerberos._udp.Default-First-Site-Name._sites.dc._msdcs.master.test.ipa. 86400 IN SRV 0 100 88 host-8-253-10.host.centralci.eng.rdu2.redhat.com.
_kerberos._tcp.dc._msdcs.master.test.ipa. 86400 IN SRV 0 100 88 host-8-253-10.host.centralci.eng.rdu2.redhat.com.
_kerberos._udp.dc._msdcs.master.test.ipa. 86400 IN SRV 0 100 88 host-8-253-10.host.centralci.eng.rdu2.redhat.com.
  [18/23]: restarting Directory Server to take MS PAC and LDAP plugins changes into account
...

Additional info:
If I run ipa-adtrust-install second time I see the expected output

Comment 1 Sergey Orlov 2019-01-10 12:03:55 UTC
The same behavior is observed also in Fedora28 and RHEL 7

Comment 2 Alexander Bokovoy 2019-01-29 14:30:49 UTC
I think it is a regression but we can fix it in a next minor release because we have a workaround:

# ipa dns-update-system-records --dry-run --out records.txt

will return you all records that need to exist for IPA to function in a format that nsupdate tool understands. If you remove '--out records.txt', then just list of the records will be provided, as expected.

Comment 3 Sergey Orlov 2019-01-30 11:01:06 UTC
Created attachment 1524991 [details]
Output of ipa-server-install

Comment 4 Sergey Orlov 2019-01-30 11:01:57 UTC
Created attachment 1524994 [details]
Output of first run of ipa-adtrust-install

Comment 5 Sergey Orlov 2019-01-30 11:02:21 UTC
Created attachment 1524995 [details]
Output of second run of ipa-adtrust-install

Comment 6 Sergey Orlov 2019-01-30 11:03:03 UTC
Created attachment 1524996 [details]
Log file of ipa-server-install and both runs of ipa-adtrust-install

Comment 20 Alexander Bokovoy 2020-02-11 16:19:51 UTC
Upstream PR: https://github.com/freeipa/freeipa/pull/4221

Comment 21 Alexander Bokovoy 2020-02-13 19:31:33 UTC
Fixed upstream
master:
https://pagure.io/freeipa/c/b3dbb36867ebf52483834ceb247050a24cf74d7c

Comment 22 Alexander Bokovoy 2020-02-14 07:26:10 UTC
Fixed upstream
ipa-4-8:
https://pagure.io/freeipa/c/936e27f75961c67e619ecfa641e256ce80662d68

Comment 28 errata-xmlrpc 2020-04-28 15:43:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1640


Note You need to log in before you can comment on or make changes to this bug.