Bug 1665153 - [host-deploy] static ipv6 is not kept after deploy and change to autoconf
Summary: [host-deploy] static ipv6 is not kept after deploy and change to autoconf
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.3.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On: 1683597
Blocks: 1403675
TreeView+ depends on / blocked
 
Reported: 2019-01-10 15:19 UTC by Roni
Modified: 2019-02-27 10:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-14 11:46:16 UTC
oVirt Team: Network


Attachments (Terms of Use)
add static ipv6 host logs (1.09 MB, application/gzip)
2019-01-10 15:19 UTC, Roni
no flags Details

Description Roni 2019-01-10 15:19:24 UTC
Created attachment 1519853 [details]
add static ipv6 host logs

Description of problem:
After adding a static IPv6 host to Engine, its ipv6 setting is changed to AutoConf

Version-Release number of selected component (if applicable):
4.3.0-0.6.alpha2.el7

How reproducible:
100%

Steps to Reproduce:
1. Install RHVH product
2. Disable IPv4 and enable static IPv6
   IPV6INIT="yes"
   BOOTPROTO="none"     <- disable IPv4, default was ‘dhcp’ 
   IPV4_FAILURE_FATAL="no"
   IPV6_AUTOCONF="no"   <- disable autoconf, default was ‘yes’
   IPV6_DEFROUTE="yes"
   IPV6_FAILURE_FATAL="no"
   IPV6ADDR=2620:52:0:2380:225:90ff:fec6:d982/64  <- add IPv6 static address
3. Restart network: “systemctl restart network“
4. At the Engine, go to Compute | Hosts and click the New button
5. Choose the right Cluster, set name & password
6. Enter the host IPv6 address at the ‘hostname’ field
7. Go to  the Hosted Engine tab and choose Deploy
8. Click Ok to start adding the host


Actual results:
Host IPv6 setting is configured as 'AutoConf'

Expected results:
Host IPv6 setting is configured as 'Static'

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=1403675

Comment 1 Dominik Holler 2019-01-11 17:24:38 UTC
Now I recognize that the return value of the first call of getCapabilities contains
'enp1s0f0': {u'ipv6autoconf': True
This means VDSM did not see the static config, even if the config file looks like this.
 
We have to check if “systemctl restart network“ applied the IPV6_AUTOCONF="no".
The content of
/proc/sys/net/ipv6/conf/%s/autoconf
/proc/sys/net/ipv6/conf/%s/accept_ra'
'/proc/sys/net/ipv6/conf/%s/accept_redirects'
has to be 0.

Comment 3 Roni 2019-01-14 11:06:16 UTC
Hi Dominik

After restarting the network service through systemctl, and also after reboot,
The content of the above keys is '1' and not '0' as you expected!

It seems that NM_CONTROLLED="no" should be also added to the ifcfg-* file
and as suggested at https://access.redhat.com/solutions/44839 
HWADDR=<NIC MAC> should be added as well.
After adding those two keys and restart network then the content of 
the above keys were changed to '0'

Thx
Roni


Note You need to log in before you can comment on or make changes to this bug.