Bug 1665303 - Review Request: rtv - A simple terminal viewer for Reddit (Reddit Terminal Viewer)
Summary: Review Request: rtv - A simple terminal viewer for Reddit (Reddit Terminal Vi...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliott Sales de Andrade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-10 22:21 UTC by Ben Rosser
Modified: 2019-08-26 21:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-26 21:30:10 UTC
quantum.analyst: fedora-review?


Attachments (Terms of Use)

Description Ben Rosser 2019-01-10 22:21:21 UTC
Spec URL: https://copr-be.cloud.fedoraproject.org/results/tc01/rtv/fedora-29-x86_64/00843741-rtv/rtv.spec
SRPM URL: https://copr-be.cloud.fedoraproject.org/results/tc01/rtv/fedora-29-x86_64/00843741-rtv/rtv-1.24.0-1.fc29.src.rpm

Description: RTV provides an interface to view and interact with reddit from your terminal.
It's compatible with most terminal emulators on Linux and OS X.
RTV is built in python using the curses library.

Fedora Account System Username: tc01

This is an un-retirement review; the package seems to have been retired because of a FTBFS on Python 3.7. However, there have been new releases upstream since the retirement; I simply updated the spec to the latest version, removed the optional Python 2 build, and rebuilt it. Everything worked as expected.

Since rtv was retired 5 months ago, I'm submitting a new review as per the un-retirement process:

https://src.fedoraproject.org/rpms/rtv/commits/master

https://fedoraproject.org/wiki/Orphaned_package_that_need_new_maintainers#Claiming_Ownership_of_a_Retired_Package

If approved, I'll submit the releng ticket to un-retire.

Comment 1 Ben Rosser 2019-01-10 22:21:58 UTC
Oh, and I forgot to explicitly link it: there are successful builds in copr here:

https://copr.fedorainfracloud.org/coprs/tc01/rtv/build/843741/

Comment 2 Miro Hrončok 2019-01-10 22:47:16 UTC
The manual requires on Python packages are unnecessary on Rawhide. 
You can opt in for this on older Fedoras as well: https://docs.fedoraproject.org/en-US/packaging-guidelines/Python/#_automatically_generated_dependencies


$ rpm -qp --requires rtv-1.24.0-1.fc30.noarch.rpm 
/usr/bin/python3
python(abi) = 3.7
python3-beautifulsoup4
python3-decorator
python3-kitchen
python3-requests >= 2.4.0
python3-six
python3.7dist(beautifulsoup4)
python3.7dist(decorator)
python3.7dist(kitchen)
python3.7dist(requests) >= 2.4.0
python3.7dist(six)



Other than that, can praw be unbundled?

Comment 3 Ben Rosser 2019-01-11 17:02:45 UTC
> The manual requires on Python packages are unnecessary on Rawhide. 

Right, I almost forgot about that. :) I'll fix this.

> Other than that, can praw be unbundled?

It looks like it can be; rtv.packages is willing to import a system version of praw instead of the bundled copy as long as the major version starts with "3."

https://github.com/michael-lazar/rtv/blob/master/rtv/packages/__init__.py

However, when I tried to build the package with praw unbundled on Rawhide, I got this...

Error: 
 Problem: conflicting requests
  - nothing provides python3-decorator < 4.1 needed by python3-praw-3.6.0-8.fc29.noarch

And indeed, looking at praw, I can see this has been an issue since Fedora 28. :( 

I'm guessing this package is not being maintained. It seems not only are there minor updates to 3.6.0 we're not shipping (3.6.2 is the latest), but there's also a 6.0 release (that I'm guessing may not be backwards compatible, hence why rtv wants to be installed against praw 3.x). https://github.com/praw-dev/praw/releases

Comment 4 Miro Hrončok 2019-01-12 13:47:01 UTC
Can this be fixed properly in praw? I can help you push changes in case the maintainer is AWOL.

Comment 5 Elliott Sales de Andrade 2019-02-06 10:49:29 UTC
praw seems pretty outdated; the packaged 3.6.0 doesn't even appear on the changelog: https://praw.readthedocs.io/en/latest/package_info/change_log.html

That is to say, I think the maintainer is very very AWOL.

Comment 6 Miro Hrončok 2019-02-06 11:10:31 UTC
Are there any changes to be pushed?

Comment 7 Ben Rosser 2019-02-07 21:19:59 UTC
Sorry for the delay on this... I did look into updating praw to 3.6.2 from 3.6.0. I discovered that, despite praw3 claiming it doesn't work with decorator >= 4.1, it actually works fine-- I was at least able to run the tests.

It looks like praw 4+ has been split into two packages, praw and "prawcore", which would be a new additional dependency.

https://github.com/praw-dev/prawcore

I have not tested if rtv works with praw 4+.

I propose to do the following for now-- does this sound like a reasonable course of action?

* Update the praw package to 3.6.2 and remove the unnecessary version requirements, to at least make it install correctly.
* Unbundle praw in rtv to use praw 3.6.2.
* Package prawcore and update praw to the latest release. If it breaks rtv, I'll either re-bundle praw 3 or work with upstream to support newer praw releases.

Comment 8 Miro Hrončok 2019-02-07 21:31:46 UTC
Sounds ideal!

Comment 9 Ben Rosser 2019-02-07 21:47:47 UTC
Great-- I'll prepare a PR for updating praw and submit it either tomorrow or Saturday.

I guess it's probably worth invoking the non-responsive maintainer policy on praw as well...

Comment 10 Ben Rosser 2019-02-12 16:33:37 UTC
Right, here's a pull request for praw:

https://src.fedoraproject.org/rpms/python-praw/pull-request/2

Comment 11 Elliott Sales de Andrade 2019-03-04 01:17:55 UTC
So we should be able to move forward with this now?

Comment 12 Ben Rosser 2019-03-11 15:49:59 UTC
Yes, sorry. The Rawhide build was still failing the last time I looked at this (about a week ago)-- I think because even though praw 3.6.2 had been built, there were compose failures. Anyway, it's working now!

Here's a version of rtv with praw unbundled (and also with rtv updated to the latest release).

Spec URL: https://copr-be.cloud.fedoraproject.org/results/tc01/rtv/fedora-29-x86_64/00866833-rtv/rtv.spec
SRPM URL: https://copr-be.cloud.fedoraproject.org/results/tc01/rtv/fedora-29-x86_64/00866833-rtv/rtv-1.26.0-1.fc29.src.rpm

Comment 13 Elliott Sales de Andrade 2019-03-17 08:28:20 UTC
- You don't provide python3-rtv, so I'm not sure using %python_provide does
  anything.
- Man pages should be globbed as rtv.1*
- Why not run tests? And if it's not possible, maybe the test BRs aren't needed
  either?

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Package does not use a name that already exists.
  Note: A package with this name already exists. Please check
  https://src.fedoraproject.org/rpms/rtv
  See: https://docs.fedoraproject.org/en-US/packaging-
  guidelines/Naming/#_conflicting_package_names


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated", "Expat License". 263 files have unknown
     license. Detailed output of licensecheck in 1665303-rtv/licensecheck.txt
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[?]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 61440 bytes in 5 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package must not depend on deprecated() packages.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[!]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Packages MUST NOT have dependencies (either build-time or runtime) on
     packages named with the unversioned python- prefix unless no properly
     versioned package exists. Dependencies on Python packages instead MUST
     use names beginning with python2- or python3- as appropriate.
[x]: Python packages must not contain %{pythonX_site(lib|arch)}/* in %files
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[!]: Final provides and requires are sane (see attachments).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[?]: Package should compile and build into binary rpms on all supported
     architectures.
[!]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: rtv-1.26.0-1.fc31.noarch.rpm
          rtv-1.26.0-1.fc31.src.rpm
rtv.noarch: W: spelling-error %description -l en_US reddit -> reedit, geddit, credit
rtv.src: W: spelling-error %description -l en_US reddit -> reedit, geddit, credit
2 packages and 0 specfiles checked; 0 errors, 2 warnings.




Rpmlint (installed packages)
----------------------------
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_CTYPE = "C.UTF-8",
	LANG = "en_CA.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_CTYPE = "C.UTF-8",
	LANG = "en_CA.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_CTYPE = "C.UTF-8",
	LANG = "en_CA.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
sh: /usr/bin/python: No such file or directory
rtv.noarch: W: spelling-error %description -l en_US reddit -> reedit, geddit, credit
rtv.noarch: W: invalid-url URL: https://github.com/michael-lazar/rtv <urlopen error [Errno -2] Name or service not known>
1 packages and 0 specfiles checked; 0 errors, 2 warnings.



Source checksums
----------------
https://github.com/michael-lazar/rtv/archive/v1.26.0/rtv-1.26.0.tar.gz :
  CHECKSUM(SHA256) this package     : 1e3c20fdbda2a1f1b584194a36895d8e42aba527b2e9fa7be8ff7fd79c8bee85
  CHECKSUM(SHA256) upstream package : 1e3c20fdbda2a1f1b584194a36895d8e42aba527b2e9fa7be8ff7fd79c8bee85


Requires
--------
rtv (rpmlib, GLIBC filtered):
    /usr/bin/python3
    python(abi)
    python3.7dist(beautifulsoup4)
    python3.7dist(decorator)
    python3.7dist(kitchen)
    python3.7dist(requests)
    python3.7dist(six)



Provides
--------
rtv:
    python3.7dist(rtv)
    python3dist(rtv)
    rtv



Generated by fedora-review 0.6.1 (29df316) last change: 2019-03-10
Command line :/home/elliott/code/FedoraReview/try-fedora-review -m fedora-rawhide-x86_64 -b 1665303
Buildroot used: fedora-rawhide-x86_64
Active plugins: Shell-api, Python, Generic
Disabled plugins: Ruby, Perl, Ocaml, Haskell, SugarActivity, Java, C/C++, R, fonts, PHP
Disabled flags: EPEL6, EPEL7, DISTTAG, BATCH, EXARCH

Comment 14 Elliott Sales de Andrade 2019-04-24 10:12:03 UTC
Ping?

Comment 15 Ben Rosser 2019-08-26 21:30:10 UTC
Hey, I'm sorry for the nonresponsiveness here.

I discovered shortly after working on this unbundling praw was much more complicated than I thought. A bunch of the unit tests failed after I tried to move to the system version of praw 3.6.2. I was planning to dig into that when I had some spare time...

...but then upstream announced that they're going to stop developing rtv:
https://github.com/michael-lazar/rtv/issues/696

There seems to be an active fork, tuir. So I think the right thing to do is close this review request and then maybe-- perhaps when I have a bit more time-- open a new one for tuir. (Of course, anyone interested in this is welcome to do that in the mean time too).

https://gitlab.com/ajak/tuir


Note You need to log in before you can comment on or make changes to this bug.