Bug 1665369
| Summary: | libreswan 3.25 in FIPS mode is incorrectly rejecting X.509 public keys that are >= 3072 bits [rhel-7.6.z] | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 7 | Reporter: | RAD team bot copy to z-stream <autobot-eus-copy> |
| Component: | libreswan | Assignee: | Paul Wouters <pwouters> |
| Status: | CLOSED ERRATA | QA Contact: | Ondrej Moriš <omoris> |
| Severity: | urgent | Docs Contact: | Mirek Jahoda <mjahoda> |
| Priority: | urgent | ||
| Version: | 7.6 | CC: | mjahoda, omoris |
| Target Milestone: | rc | Keywords: | ZStream |
| Target Release: | --- | ||
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | libreswan-3.25-4.1.el7_6 | Doc Type: | Bug Fix |
| Doc Text: |
While running in FIPS mode, Libreswan incorrectly checked the length of X.509 public keys as if it is in bytes. Consequently, 3072-bit keys were incorrectly detected as 384-bit and rejected. With this update, the check has been fixed to count with bits instead of bytes, and the keys are no longer incorrectly rejected in the described scenario.
|
Story Points: | --- |
| Clone Of: | 1664521 | Environment: | |
| Last Closed: | 2019-01-29 17:22:58 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1664521 | ||
| Bug Blocks: | |||
|
Description
RAD team bot copy to z-stream
2019-01-11 07:29:26 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHEA-2019:0178 |