Bug 1665382 - Better to restrict filename of '--to' in 'oc registry login'
Summary: Better to restrict filename of '--to' in 'oc registry login'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Maciej Szulik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-11 08:37 UTC by XiuJuan Wang
Modified: 2019-06-04 10:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:55 UTC

Description XiuJuan Wang 2019-01-11 08:37:19 UTC
Description of problem:
1.Special characters can be included in filename for '--to'
2.The filename has no length restricted.

Version-Release number of selected component (if applicable):
oc v4.0.0-0.130.0
kubernetes v1.11.0+f67f40dbad


How reproducible:
always

Steps to Reproduce:
1.oc registry login --to=abcd#
2.
3.

Actual results:
abcd# will be generated under current dir

Expected results:
It's better to warn special characters forbidden
Better to restrict filename length

Additional info:

Comment 2 Maciej Szulik 2019-02-28 21:00:53 UTC
This is working as expected, moving to qa.

Comment 3 XiuJuan Wang 2019-03-01 02:22:03 UTC
As comment #2, move it to verify

Comment 6 errata-xmlrpc 2019-06-04 10:41:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.