Bug 1665419 - Hosted engine wizard displays "System data could not be retrieved!" is eth0 is not available on the host
Summary: Hosted engine wizard displays "System data could not be retrieved!" is eth0 i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-4.3.0
: ---
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-11 10:22 UTC by Wei Wang
Modified: 2019-05-08 12:32 UTC (History)
12 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.3.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-08 12:32:03 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)
Picture (27.88 KB, image/png)
2019-01-11 10:22 UTC, Wei Wang
no flags Details
Log file (523.13 KB, application/gzip)
2019-01-11 10:24 UTC, Wei Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 96883 0 master MERGED Fix get_network_interfaces.yml execution for cockpit 2020-08-03 17:07:22 UTC

Description Wei Wang 2019-01-11 10:22:04 UTC
Created attachment 1519996 [details]
Picture

Description of problem:
Hosted engine wizard displays "System data could not be retrieved!". Cannot deploy hosted-engine via cockpit UI.

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.3-20190109.0.el7_6.x86_64.liveimg.squashfs
cockpit-176-4.el7.x86_64
cockpit-dashboard-176-4.el7.x86_64
cockpit-system-176-4.el7.noarch
cockpit-ws-176-4.el7.x86_64
cockpit-ovirt-dashboard-0.12.0-1.el7ev.noarch
cockpit-machines-ovirt-176-4.el7.noarch
cockpit-bridge-176-4.el7.x86_64
virt-hosted-engine-setup-2.3.0-1.el7ev.noarch
ovirt-hosted-engine-ha-2.3.0-1.el7ev.noarch
firefox-62.0-2.fc28.x86_64
google-chrome-stable-68.0.3440.106-1.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Clean install redhat-virtualization-host-4.3-20190109.0.el7_6.x86_64.liveimg.squashfs
2. Login to http://<host IP>:9090 with root account
3. Go to Virtualization->hosted-engine
4. Click "Start" of Hosted Engine

Actual results:
Hosted engine wizard displays "System data could not be retrieved!"

Expected results:
Hosted engine should display wizard for setting without error

Additional info:
The issue occurs with Firefox and Chrome browsers

Comment 1 Wei Wang 2019-01-11 10:24:56 UTC
Created attachment 1519997 [details]
Log file

Comment 3 Nikolai Sednev 2019-01-16 12:15:44 UTC
It seams like RHVH specific. I didn't seen it happening on regular RHEL deployments.

Comment 4 Wei Wang 2019-01-17 00:22:57 UTC
(In reply to Nikolai Sednev from comment #3)
> It seams like RHVH specific. I didn't seen it happening on regular RHEL
> deployments.

Comment 5 Simone Tiraboschi 2019-01-17 13:05:16 UTC
No, it wasn't RHVH specific.
It was descending from here: https://github.com/oVirt/ovirt-ansible-hosted-engine-setup/blob/master/defaults/main.yml#L65

In ovirt-ansible-hosted-engine-setup we have eth0 as a default so everything was fine if eth0 was on the host otherwise it was failing.

Comment 6 Nikolai Sednev 2019-01-20 13:16:26 UTC
ovirt-hosted-engine-setup-2.3.2-1.el7ev.noarch
ovirt-hosted-engine-ha-2.3.0-1.el7ev.noarch
rhvm-appliance-4.3-20190115.0.el7.x86_64

I successfully deployed HE over NFS using ethernet interface different than eth0.
Original error wasn't reproduced.
Moving to verified.

Comment 8 errata-xmlrpc 2019-05-08 12:32:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1050


Note You need to log in before you can comment on or make changes to this bug.