Bug 166543 - NFS Stale locks when NFS export moves to another node
NFS Stale locks when NFS export moves to another node
Status: CLOSED DUPLICATE of bug 132823
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Cluster QE
Depends On:
  Show dependency treegraph
Reported: 2005-08-23 01:11 EDT by Alex Samad
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-20 16:50:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
cluster conf file (4.44 KB, text/plain)
2005-08-23 01:11 EDT, Alex Samad
no flags Details
rmtab file from 4 nodes (542 bytes, text/plain)
2005-08-23 01:13 EDT, Alex Samad
no flags Details

  None (edit)
Description Alex Samad 2005-08-23 01:11:46 EDT
Description of problem:
I have setup a 4 node cluster with gfs (AS4, Cluster Suite4, GFS 6.1).  I have 
3 gfs partitions that I am trying to export via nfs. This has been done and I 
can mount them on another redhat AS3 box. When I move the nfs shares to other 
nodes to simulate a failover I get stale nfs handle errors on the client 

Upon investigation I found a article for cluster suite 3, about setting FS for 
nfs shares as these need to be the same for each node.  This seems to have 
been removed (the ability to set options, through the gui), but the 
documentation states that clurmtabd should handle this.

I have run cat /var/lib/nfs/rmtab on all the nodes when it is working (before 
the move and after, when I am getting the stale nfs handles) and the numbers 
are  not similiar or consistant across the nodes. NOTE- I am making assumption 
the numbers in these files are the FS numbers.

I have checked the major minor numbers for all the base devices (lvm 
partitions) and they are the same on all the machines!

here is an example output pre move
forall cat /var/lib/nfs/rmtab \; echo

and after 

[samad@rhnsat test]$ forall cat /var/lib/nfs/rmtab \; echo

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.start cluster
2. mount nfs exports
3. move nfs export to new node
Actual results:
I get nfs stale locks on the client machine

Expected results:
the nfs shafre should seemlessly failover to new node

Additional info:
Comment 1 Alex Samad 2005-08-23 01:11:46 EDT
Created attachment 117989 [details]
cluster conf file
Comment 2 Alex Samad 2005-08-23 01:13:17 EDT
Created attachment 117990 [details]
rmtab file from 4 nodes

this shows the rmtab file from all the nodes
Comment 5 Lon Hohberger 2005-10-04 17:28:45 EDT
Assigning to NFS maintainer, but staying on CC list for now.
Comment 9 Kiersten (Kerri) Anderson 2005-10-20 16:50:32 EDT
We think this is a dup of the NFS Failover defect so are going to close it as
such and link it to that one- BZ 132823.

*** This bug has been marked as a duplicate of 132823 ***
Comment 10 Axel Thimm 2005-10-20 17:35:51 EDT
bug #132823 is protected. Could it be opened to the public? Otherwise it would
be good to keep this one open to have something to track.

Note You need to log in before you can comment on or make changes to this bug.