Bug 1665461 - Dynlfow undefined method `dynflow_logger'
Summary: Dynlfow undefined method `dynflow_logger'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Tasks Plugin
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.4.2
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On: 1654217
Blocks: 1628638 1661291
TreeView+ depends on / blocked
 
Reported: 2019-01-11 13:35 UTC by Ivan Necas
Modified: 2019-10-30 19:28 UTC (History)
3 users (show)

Fixed In Version: tfm-rubygem-dynflow-1.0.5.2-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1654217
Environment:
Last Closed: 2019-02-13 19:08:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 25566 None None None 2019-01-11 13:56:13 UTC
Red Hat Product Errata RHBA-2019:0345 None None None 2019-02-13 19:08:23 UTC

Comment 6 jcallaha 2019-01-24 21:42:11 UTC
Verified in Satellite 6.4.2 Snap 1

I followed the reproducer steps outlined in the initial report.

After making the config changes, and restarting the foreman-tasks service, I kicked off a number of repository sync jobs as well as content view publishes.

At no point did the reported error manifest.

-bash-4.2# grep "ERROR -- /clock:" /var/log/foreman/dynflow_executor.output
-bash-4.2#

Comment 8 errata-xmlrpc 2019-02-13 19:08:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0345


Note You need to log in before you can comment on or make changes to this bug.