Bug 1665552 - Log spam: openshift-apiserver-operator list image failure every second.
Summary: Log spam: openshift-apiserver-operator list image failure every second.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 4.1.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: 4.1.0
Assignee: David Eads
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-11 18:23 UTC by Mike Fiedler
Modified: 2019-06-04 10:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
openshift-apiserver-operator pod logs (55.50 KB, application/gzip)
2019-01-11 18:23 UTC, Mike Fiedler
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:55 UTC

Description Mike Fiedler 2019-01-11 18:23:44 UTC
Created attachment 1520114 [details]
openshift-apiserver-operator pod logs

Description of problem:

openshift-apiserver-operator is logging the following Error message every second:

E0111 18:16:36.673453       1 reflector.go:205] github.com/openshift/cluster-openshift-apiserver-operator/vendor/github.com/openshift/client-go/config/informers/externalversions/factory.go:101: Failed to list *v1.Image: the server could not find the requested resource (get images.config.openshift.io)

This is on an OCP install.


Version-Release number of selected component (if applicable): 4.0.0-0.nightly-2019-01-10-165754


How reproducible: Always


Steps to Reproduce:
1. Install typical 3 master/3 worker cluster with openshift-install on AWS
2. oc logs -n openshift-apiserver-operator <pod>

Actual results:

List failure logged as an Error that pops every second

Expected results:

If it is not an error, lower the log level.  If it is an error, is there something that needs to be fixed?  Not sure of that part.

Additional info:

Full logs attached

Comment 1 Michal Fojtik 2019-02-20 09:54:30 UTC
Low prio and I think we recently improved/remove this message. It is transient and goes away when the CRD become available, informer caches are synced and we can get the image config Ben provide to us.

Comment 2 David Eads 2019-03-05 15:22:12 UTC
fixed a long time ago with cluster-config-operator

Comment 3 Mike Fiedler 2019-03-06 15:43:09 UTC
Verfied on 4.0.0-0.nightly-2019-03-06-074438

Comment 6 errata-xmlrpc 2019-06-04 10:41:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.