Bug 1665599 - openshift-apiserver: many "unable to encode watch object: expected pointer, but got invalid kind" errors
Summary: openshift-apiserver: many "unable to encode watch object: expected pointer, ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: David Eads
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-11 21:56 UTC by Mike Fiedler
Modified: 2019-06-04 10:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
openshift-apiserver pod log (7.65 KB, application/gzip)
2019-01-11 21:56 UTC, Mike Fiedler
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:55 UTC

Description Mike Fiedler 2019-01-11 21:56:17 UTC
Created attachment 1520146 [details]
openshift-apiserver pod log

Description of problem:

The openshift-apiserver pod logs show many error messages:

E0111 21:36:05.155595       1 watch.go:212] unable to encode watch object: expected pointer, but got invalid kind 

They are not at regular intervals


Version-Release number of selected component (if applicable): 4.0.0-0.nightly-2019-01-10-165754


How reproducible: Always


Steps to Reproduce:
1. Install typical 3 master/3 worker next gen cluster on AWS using the OCP payload (4.0.0-0.nightly-2019-01-10-165754)
2. oc logs -n openshift-apiserver <apiserver_pod>

Actual results:
Many instances of

E0111 21:36:05.155595       1 watch.go:212] unable to encode watch object: expected pointer, but got invalid kind 


Additional info:

Full pod log attached

Comment 2 Mike Fiedler 2019-03-07 19:13:55 UTC
Verified on 4.0.0-0.ci-2019-03-05-024322.   Only 3 instances of this error in the logs.

Comment 5 errata-xmlrpc 2019-06-04 10:41:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.