Bug 166560 - Install hang when press last next button, when would be show progress bar
Install hang when press last next button, when would be show progress bar
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 166559 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-23 07:38 EDT by Dario Lesca
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 11:08:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dario Lesca 2005-08-23 07:38:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I have use the anaconda/anaconda-runtime procedure for rebuild a patched fc4 structure. If I run the procedure on a FC3 system, the result FC4 structure is OK, I have test it to master on a DVD and via PXE/NFS setup.
If I run the build procedure on a FC4 system, the result structure not work property, when I press the last next button, when the anaconda would show the progress bar, the procedure crash whit this error:
------
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 876, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1198, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/progress_gui.py", line 335, in getScreen
    progressTable.attach (self.totalProgress, 1, 2, 0, 1, ypadding=2)
TypeError: GtkTable.attach() argument 8, item 51161979, item 2291839, item 383, item 162057759, item 8789343, item 160766871, item 5 impossible<bad format char>
######################

I have patch the anaconda package whit this patch:

#####################################
--- anaconda-10.2.1.5/iw/progress_gui.py.old    2005-08-23 12:11:31.334113136 +0200
+++ anaconda-10.2.1.5/iw/progress_gui.py        2005-08-23 12:12:48.843329944 +0200
@@ -332,7 +332,7 @@
         self.totalProgress = gtk.ProgressBar ()

        progressTable = gtk.Table (2, 2, False)
-       progressTable.attach (self.totalProgress, 1, 2, 0, 1, ypadding=2)
+       progressTable.attach (self.totalProgress, 1, 2, 0, 1, xpadding=0, ypadding=2)

 #      label = gtk.Label (_("Package Progress: "))
 #      label.set_alignment (1.0, 0.5)
-------------------------------------------
and the problem is solved.


Version-Release number of selected component (if applicable):
anaconda-10.2.1.5-2

How reproducible:
Always

Steps to Reproduce:
1. Rebuild the FC4 struct with the anaconda-* package
2. Start a NFS setup from  new structure
3. Select a tipical installation....
  

Actual Results:  When press the last next button, before the setup procedure start a Pyton error appears and the setup exit.


Expected Results:  The setup would have to continue with a progress bar

Additional info:

On web I have found this article:

  http://lists.progeny.com/archive/anaconda-workers/200506/msg00004.html

.. and ... Sorry for my bad english :-(
Comment 1 Jeremy Katz 2005-08-23 11:08:16 EDT
This is due to a pygtk bug that's only present with some combination of newer
packages.  See http://bugzilla.gnome.org/show_bug.cgi?id=300012

We've got fixes for this in the development version of anaconda and it won't
reproduce with the exact packages shipped in RHEL4 GA
Comment 2 Jeremy Katz 2005-08-23 11:11:37 EDT
*** Bug 166559 has been marked as a duplicate of this bug. ***
Comment 3 Dario Lesca 2005-08-23 11:24:23 EDT
Ok, but, howTo I can resolve my problem whitout patch the fc4 version of
anaconda (anaconda-10.2.1.5-2)?
There is a new version of anaconda with a workaround or I must update Pyton?
What is the best solution?

Many thanks for reply.

D.L.

Note You need to log in before you can comment on or make changes to this bug.