Bug 1665608 - [abrt] nl80211_set_pmk: WARNING: CPU: 4 PID: 5427 at drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c:5122 brcmf_cfg80211_set_pmk+0x2f/0x40 [brcmfmac] [cfg80211]
Summary: [abrt] nl80211_set_pmk: WARNING: CPU: 4 PID: 5427 at drivers/net/wireless/bro...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:74113874f9c6c32b741b51b1af1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-11 23:31 UTC by Steven R. Loomis
Modified: 2019-07-03 19:29 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-03 19:29:23 UTC


Attachments (Terms of Use)
File: dmesg (93.15 KB, text/plain)
2019-01-11 23:32 UTC, Steven R. Loomis
no flags Details
Dmesg Dell XPS 15 (153.51 KB, text/plain)
2019-02-06 10:12 UTC, Enrico Tagliavini
no flags Details

Description Steven R. Loomis 2019-01-11 23:31:59 UTC
Description of problem:
Trying to use WPA 2 Enterprise (TLS)

sys: MacBookPro11,5
net: Network controller: Broadcom Inc. and subsidiaries BCM43602 802.11ac Wireless LAN SoC (rev 01)

Additional info:
reporter:       libreport-2.9.7
WARNING: CPU: 4 PID: 5427 at drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c:5122 brcmf_cfg80211_set_pmk+0x2f/0x40 [brcmfmac]
Modules linked in: xt_CHECKSUM ipt_MASQUERADE tun bridge stp llc devlink nf_nat_ftp nf_conntrack_ftp xt_CT ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ip6table_nat nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_nat_ipv4 nf_nat iptable_mangle iptable_raw iptable_security nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c ip_set nfnetlink ebtable_filter ebtables ip6table_filter ip6_tables cmac bnep sunrpc nls_utf8 hfsplus joydev intel_rapl x86_pkg_temp_thermal iTCO_wdt intel_powerclamp iTCO_vendor_support coretemp kvm_intel kvm brcmfmac applesmc input_polldev btusb btrtl btbcm irqbypass btintel intel_cstate brcmutil bluetooth intel_uncore cfg80211 intel_rapl_perf snd_hda_codec_cirrus snd_hda_codec_generic snd_hda_codec_hdmi snd_hda_intel
 snd_hda_codec ecdh_generic snd_hda_core mmc_core bcm5974 snd_hwdep snd_seq rfkill snd_seq_device thunderbolt snd_pcm snd_timer mei_me snd mei lpc_ich i2c_i801 soundcore intel_pch_thermal sbs acpi_als kfifo_buf sbshc industrialio apple_gmux pcc_cpufreq video apple_bl dm_crypt amdgpu chash gpu_sched radeon i2c_algo_bit drm_kms_helper crct10dif_pclmul crc32_pclmul crc32c_intel ttm drm uas ghash_clmulni_intel usb_storage hid_apple
CPU: 4 PID: 5427 Comm: wpa_supplicant Not tainted 4.19.13-300.fc29.x86_64 #1
Hardware name: Apple Inc. MacBookPro11,5/Mac-06F11F11946D27C5, BIOS MBP114.88Z.0184.B00.1806051659 06/05/2018
RIP: 0010:brcmf_cfg80211_set_pmk+0x2f/0x40 [brcmfmac]
Code: 48 8b 86 c8 08 00 00 48 8d be c0 08 00 00 83 b8 80 07 00 00 02 75 13 0f b6 42 08 3c 20 77 13 48 8b 72 10 89 c2 e9 b1 fe ff ff <0f> 0b b8 ea ff ff ff c3 b8 de ff ff ff c3 0f 1f 00 0f 1f 44 00 00
RSP: 0018:ffffb5ce83927aa8 EFLAGS: 00010293
RAX: ffff9b11a1343000 RBX: ffffb5ce83927b50 RCX: ffff9b11aa9ca000
RDX: ffffb5ce83927ab0 RSI: ffff9b11a1347000 RDI: ffff9b11a13478c0
RBP: 00000000ffffff95 R08: ffffffffc0ac4fe0 R09: ffff9b11aa9ca000
R10: ffff9b11ae85fb78 R11: 0000000000000000 R12: ffff9b11a1343050
R13: ffff9b11a1347000 R14: ffff9b119e748000 R15: ffff9b119e7482e0
FS:  00007f766eb9e180(0000) GS:ffff9b11af100000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00005619f381e000 CR3: 000000045ceea002 CR4: 00000000001606e0
Call Trace:
 nl80211_set_pmk+0x178/0x240 [cfg80211]
 genl_family_rcv_msg+0x1ca/0x3a0
 ? skb_queue_tail+0x1b/0x50
 ? __netlink_sendskb+0x51/0x70
 genl_rcv_msg+0x47/0x8c
 ? __kmalloc_node_track_caller+0x1df/0x2a0
 ? genl_family_rcv_msg+0x3a0/0x3a0
 netlink_rcv_skb+0x4c/0x120
 genl_rcv+0x24/0x40
 netlink_unicast+0x19e/0x260
 netlink_sendmsg+0x1ff/0x3c0
 sock_sendmsg+0x36/0x40
 ___sys_sendmsg+0x295/0x2f0
 ? __inode_wait_for_writeback+0x7f/0xf0
 ? init_wait_var_entry+0x40/0x40
 ? fsnotify_grab_connector+0x3c/0x60
 ? __dentry_kill+0x10b/0x160
 ? _cond_resched+0x15/0x30
 ? dentry_kill+0x47/0x170
 __sys_sendmsg+0x57/0xa0
 do_syscall_64+0x5b/0x160
 entry_SYSCALL_64_after_hwframe+0x44/0xa9
RIP: 0033:0x7f766f09bb58
Code: 89 02 48 c7 c0 ff ff ff ff eb b5 0f 1f 80 00 00 00 00 f3 0f 1e fa 48 8d 05 c5 6b 0c 00 8b 00 85 c0 75 17 b8 2e 00 00 00 0f 05 <48> 3d 00 f0 ff ff 77 58 c3 0f 1f 80 00 00 00 00 41 54 41 89 d4 55
RSP: 002b:00007ffcb4087048 EFLAGS: 00000246 ORIG_RAX: 000000000000002e
RAX: ffffffffffffffda RBX: 00005619f37b6f30 RCX: 00007f766f09bb58
RDX: 0000000000000000 RSI: 00007ffcb4087080 RDI: 0000000000000006
RBP: 00005619f382b290 R08: 0000000000000000 R09: 000000000000000d
R10: 00005619f37ac010 R11: 0000000000000246 R12: 00005619f37b6e40
R13: 00007ffcb4087080 R14: ffffffffffffffff R15: 0000000000000000

Comment 1 Steven R. Loomis 2019-01-11 23:32:04 UTC
Created attachment 1520152 [details]
File: dmesg

Comment 2 Enrico Tagliavini 2019-02-06 10:12:57 UTC
Created attachment 1527457 [details]
Dmesg Dell XPS 15

Same here, cannot connect to any WPA Enterprise network

Comment 3 zhangks98 2019-03-23 06:54:07 UTC
Description of problem:
Connecting to PEAP network

Version-Release number of selected component:
kernel-core-4.20.16-200.fc29

Additional info:
reporter:       libreport-2.10.0
cmdline:        BOOT_IMAGE=/vmlinuz-4.20.16-200.fc29.x86_64 root=/dev/mapper/fedora-root ro resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8
crash_function: nl80211_set_pmk
kernel:         4.20.16-200.fc29.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 1031 at drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c:5130 brcmf_cfg80211_set_pmk+0x2f/0x40 [brcmfmac]
Modules linked in: fuse rfcomm iptable_mangle xt_CHECKSUM iptable_nat ipt_MASQUERADE nf_nat_ipv4 nf_nat xt_conntrack nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c tun bridge stp llc devlink ebtable_filter ebtables ip6table_filter ip6_tables cmac bnep sunrpc nls_utf8 hfsplus intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm irqbypass joydev iTCO_wdt iTCO_vendor_support crct10dif_pclmul applesmc crc32_pclmul input_polldev ghash_clmulni_intel intel_cstate snd_hda_codec_cirrus intel_uncore snd_hda_codec_generic brcmfmac snd_hda_codec_hdmi intel_rapl_perf btusb snd_hda_intel btrtl btbcm btintel brcmutil snd_hda_codec bluetooth cfg80211 snd_hda_core snd_hwdep snd_seq snd_seq_device snd_pcm mmc_core ecdh_generic snd_timer rfkill bcm5974 mei_me i2c_i801 intel_pch_thermal thunderbolt snd lpc_ich mei soundcore sbs acpi_als kfifo_buf sbshc industrialio apple_gmux apple_bl pcc_cpufreq amdgpu chash amd_iommu_v2 gpu_sched radeon i2c_algo_bit drm_kms_helper ttm
 drm uas crc32c_intel usb_storage video hid_apple
CPU: 0 PID: 1031 Comm: wpa_supplicant Not tainted 4.20.16-200.fc29.x86_64 #1
Hardware name: Apple Inc. MacBookPro11,5/Mac-06F11F11946D27C5, BIOS 187.0.0.0.0 09/17/2018
RIP: 0010:brcmf_cfg80211_set_pmk+0x2f/0x40 [brcmfmac]
Code: 48 8b 86 c8 08 00 00 48 8d be c0 08 00 00 83 b8 80 07 00 00 02 75 13 0f b6 42 08 3c 20 77 13 48 8b 72 10 89 c2 e9 b1 fe ff ff <0f> 0b b8 ea ff ff ff c3 b8 de ff ff ff c3 0f 1f 00 0f 1f 44 00 00
RSP: 0018:ffffbed9c28bfaa8 EFLAGS: 00010293
RAX: ffff9c4d69177000 RBX: ffffbed9c28bfb50 RCX: ffff9c4d60ce3000
RDX: ffffbed9c28bfab0 RSI: ffff9c4d69172000 RDI: ffff9c4d691728c0
RBP: 00000000ffffff95 R08: 00000000000000fe R09: ffff9c4d60ce3000
R10: 0000000000000000 R11: ffffffff9031d118 R12: ffff9c4d69177050
R13: ffff9c4d69172000 R14: ffff9c4d67590000 R15: ffff9c4d67590300
FS:  00007f97fd5663c0(0000) GS:ffff9c4d6f000000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 000055fd2972a368 CR3: 0000000450cc8001 CR4: 00000000001606f0
Call Trace:
 nl80211_set_pmk+0x178/0x240 [cfg80211]
 genl_family_rcv_msg+0x1ca/0x3b0
 ? skb_queue_tail+0x1b/0x50
 ? __netlink_sendskb+0x51/0x70
 genl_rcv_msg+0x47/0x8c
 ? __kmalloc_node_track_caller+0x1df/0x2a0
 ? genl_family_rcv_msg+0x3b0/0x3b0
 netlink_rcv_skb+0x4c/0x120
 genl_rcv+0x24/0x40
 netlink_unicast+0x19e/0x260
 netlink_sendmsg+0x204/0x3d0
 sock_sendmsg+0x36/0x40
 ___sys_sendmsg+0x295/0x2f0
 ? __inode_wait_for_writeback+0x7f/0xf0
 ? fsnotify_grab_connector+0x3c/0x60
 ? fsnotify_destroy_marks+0x22/0xf0
 ? __dentry_kill+0x10b/0x160
 ? _cond_resched+0x15/0x30
 ? dentry_kill+0x47/0x170
 __sys_sendmsg+0x57/0xa0
 do_syscall_64+0x5b/0x160
 entry_SYSCALL_64_after_hwframe+0x44/0xa9
RIP: 0033:0x7f97fda65b58
Code: 89 02 48 c7 c0 ff ff ff ff eb b5 0f 1f 80 00 00 00 00 f3 0f 1e fa 48 8d 05 c5 6b 0c 00 8b 00 85 c0 75 17 b8 2e 00 00 00 0f 05 <48> 3d 00 f0 ff ff 77 58 c3 0f 1f 80 00 00 00 00 41 54 41 89 d4 55
RSP: 002b:00007fff9d690988 EFLAGS: 00000246 ORIG_RAX: 000000000000002e
RAX: ffffffffffffffda RBX: 000055fd296b14d0 RCX: 00007f97fda65b58
RDX: 0000000000000000 RSI: 00007fff9d6909c0 RDI: 0000000000000007
RBP: 000055fd296b79d0 R08: 0000000000000000 R09: 000000000000000d
R10: 000055fd296a7010 R11: 0000000000000246 R12: 000055fd296b1ef0
R13: 00007fff9d6909c0 R14: ffffffffffffffff R15: 0000000000000000

Comment 4 Harold Campbell 2019-03-26 17:15:57 UTC
No change with 5.0.3-200, FWIW.

Comment 5 Laura Abbott 2019-04-09 20:45:45 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 29 kernel bugs.
 
Fedora XX has now been rebased to 5.0.6  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 30, and are still experiencing this issue, please change the version to Fedora 30.
 
If you experience different issues, please open a new bug report for those.

Comment 6 Harold Campbell 2019-04-09 22:40:40 UTC
kernel-5.0.6-300.fc30.x86_64

No change.

Comment 7 Richard Fearn 2019-04-18 08:57:42 UTC
Same problem here on a mid-2015 MacBook Pro, running Fedora 29, kernel 5.0.7-200. The workaround described here:

  https://bugs.archlinux.org/task/61119

seems to work - edit /etc/sysconfig/wpa_supplicant to contain:

  INTERFACES="-iwlp3s0"
  DRIVERS="-Dwext"

(changing 'wlp3s0' to whatever your interface is called, if necessary) and then:

  $ sudo systemctl restart wpa_supplicant

to make wpa_supplicant use the new options. Then try to connect.

(I tried with just the DRIVERS line but the problem still occurred; adding INTERFACES was required too.)

Comment 8 Harold Campbell 2019-05-14 17:05:59 UTC
As of kernel-5.0.13-300.fc30.x86_64 and/or wpa_supplicant-2.8-2.fc30.x86_64, I'm back in business without the -Dwext workaround.

Comment 9 Peter Robinson 2019-06-16 09:54:33 UTC
Upstream thread, hopefully that will get to the bottom of it:
https://www.spinics.net/lists/linux-wireless/msg187184.html

Comment 10 Steven R. Loomis 2019-07-03 19:22:39 UTC
As the original reporter, this is now fixed after an update to f30!

- wpa_supplicant-2.8-2.fc30.x86_64
- kernel-5.1.15-300.fc30.x86_64

So, I think this should be closed as a duplicate of something.


Note You need to log in before you can comment on or make changes to this bug.