Bug 1665649 - nmcli connection modify +ipv4.dns-options does not append
Summary: nmcli connection modify +ipv4.dns-options does not append
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.1
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1682336
Blocks: 1676635
TreeView+ depends on / blocked
 
Reported: 2019-01-12 02:01 UTC by Curtis Taylor
Modified: 2020-11-14 13:15 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1676635 (view as bug list)
Environment:
Last Closed: 2019-11-05 22:29:15 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3623 0 None None None 2019-11-05 22:30:36 UTC

Description Curtis Taylor 2019-01-12 02:01:43 UTC
Description of problem:
nmcli connection modify +ipv4.dns-options does not append options

Version-Release number of selected component (if applicable):
RHEL8 beta NetworkManager-1.14.0-5.el8.x86_64

How reproducible:
RHEL8 beta or RHEL7 any release, notice how dns-options does not behave the same as dns-search though both are array of string according to nm-settings manpage.

Steps to Reproduce:
1.
# nmcli con mod "System ens3" ipv4.dns-search "abc.com"
# nmcli con mod "System ens3" ipv4.dns-options "ndots:2"

2.
# nmcli con show "System ens3" | grep -e ipv4.dns-search -e ipv4.dns-options
ipv4.dns-search:                        abc.com
ipv4.dns-options:                       "ndots:2"

3.
# nmcli con mod "System ens3" +ipv4.dns-search "redhat.com"
# nmcli con mod "System ens3" +ipv4.dns-options "timeout:2"


Actual results:

dns-options contains only timeout:2

# nmcli con show "System ens3" | grep -e ipv4.dns-search -e ipv4.dns-options
ipv4.dns-search:                        abc.com,redhat.com
ipv4.dns-options:                       "timeout:2"


Expected results:  

dns-options should contain both ndots:2 and timeout:2

# nmcli con show "System ens3" | grep -e ipv4.dns-search -e ipv4.dns-options
ipv4.dns-search:                        abc.com,redhat.com
ipv4.dns-options:                       "ndots:2 timeout:2"


Additional info:
dns-options should behave the same as dns-search since:
# man nm-settings 2>/dev/null | grep -e dns-options -e dns-search 
       │dns-options        │ array of string          │ []            │ Array of DNS options as  │
       │dns-search         │ array of string          │ []            │ Array of DNS search      │

Comment 2 Beniamino Galvani 2019-01-12 22:12:07 UTC
Fixed upstream:

  https://gitlab.freedesktop.org/NetworkManager/NetworkManager/commit/9b0c1ef5d001ad0b2b9173e104871c91f4c95426

Note that it's also possible to specify multiple options in the same command:

  nmcli connection modify "System ens3" ipv4.dns-options debug,rotate,ndots:5

Comment 12 sushil kulkarni 2019-09-17 15:19:33 UTC
Taking out of the 8.2 RPL.. Fix already in 8.1

Comment 14 errata-xmlrpc 2019-11-05 22:29:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3623


Note You need to log in before you can comment on or make changes to this bug.