Bug 1665705 - The ES dedicated master pod couldn't be started
Summary: The ES dedicated master pod couldn't be started
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-13 07:11 UTC by Anping Li
Modified: 2019-06-04 10:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:55 UTC

Description Anping Li 2019-01-13 07:11:38 UTC
Description of problem:
The ES es-node-master only pod couldn't be started. The elasticsearch-storage is not defined in statefulset/elasticsearch-master-1. 


#oc get events
45m       45m       7         elasticsearch-clientdatamaster-0-2-67556c645b-rpdtt.157953831d11002a   Pod       spec.containers{elasticsearch}   Warning   Unhealthy   kubelet, ip-10-0-144-241.eu-west-2.compute.internal   Readiness probe failed: cat: /opt/app-root/src/init_failures: No such file or directory

17s       4m        23        elasticsearch-master-1.157955cc140a8304   StatefulSet             Warning   FailedCreate   statefulset-controller   create Pod elasticsearch-master-1-0 in StatefulSet elasticsearch-master-1 failed error: Pod "elasticsearch-master-1-0" is invalid: spec.containers[0].volumeMounts[0].name: Not found: "elasticsearch-storage"


Version-Release number of selected component (if applicable):
registry.reg-aws.openshift.com:443/openshift/ose-elasticsearch-operator:v4.0
registry.reg-aws.openshift.com:443/openshift/ose-elasticsearch-operator@sha256:a8db9520060d448fcf75e0d3684194b64c54c8bb7c3770e72948293db3b98c03

How reproducible:
Always

Steps to Reproduce:
1. Add ES master only nodeSpec in CRD Elalasticsearch
  nodes:
  - nodeCount: 2
    nodeSpec:
      resources: {}
    roles:
    - client
    - data
    - master
    storage: {}
  - nodeCount: 1
    nodeSpec:
      resources: {}
    roles:
    - master
    storage: {}
  redundancyPolicy: SingleRedundancy
2. Check the ES pod and Event
  #oc get statefulset
  #oc get pods --selector es-node-master=true,es-node-data=false
  #oc get event

Actual results:

The pod can be started for elasticsearch-storage is not defined in statefulset

Expected results:
The pod can be started.
If we remove the persistent volume from elasticsearch, 


Additional info:

Comment 1 Jeff Cantrill 2019-01-15 15:18:18 UTC
Targeting to 4.1 as this is not supported in 4.0

Comment 2 Jeff Cantrill 2019-03-01 22:09:03 UTC
Moving to 4.1 as no intention to support in 4.0

Comment 4 Qiaoling Tang 2019-03-26 09:03:32 UTC
Pod can start, move to VERIFIED.

$ oc get pod
NAME                                                  READY   STATUS    RESTARTS   AGE
cluster-logging-operator-86c45f64dc-ksjmz             1/1     Running   0          18m
elasticsearch-clientdatamaster-0-1-59f4cc864-j4wg9    2/2     Running   0          5m27s
elasticsearch-clientdatamaster-0-2-6b58c74f6d-dzgbs   2/2     Running   0          5m19s
elasticsearch-master-1-0                              2/2     Running   0          39s

$ oc get statefulset
NAME                     READY   AGE
elasticsearch-master-1   1/1     53s

Comment 7 errata-xmlrpc 2019-06-04 10:41:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.