Bug 1665824 - No image quay.io/openshift/cluster-logging-operator:latest and quay.io/openshift/elasticsearch-operator:latest
Summary: No image quay.io/openshift/cluster-logging-operator:latest and quay.io/open...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-14 08:12 UTC by Anping Li
Modified: 2019-06-04 10:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:02 UTC
Github openshift cluster-logging-operator pull 83 None None None 2019-01-14 21:03:01 UTC
Github openshift elasticsearch-operator pull 63 None None None 2019-01-14 21:10:24 UTC

Description Anping Li 2019-01-14 08:12:21 UTC
Description of problem:
By default, the image name is quay.io/openshift/cluster-logging-operator:latest. But the image name is quay.io/openshift/origin-cluster-logging-operator:latest

Version-Release number of selected component (if applicable):
4.x

How reproducible:
Alway

Steps to Reproduce:
1. deploy logging via OLM
2.
3.

Actual results:
The cluster-logging and elasticsearch operator couldn't be started.


Expected results:
The cluster-logging and elasticsearch operator can be started.

Additional info:

Comment 1 Anping Li 2019-01-14 08:14:25 UTC
@jeff Please assign to the ART team if the image should be retagged by them.

Comment 2 Anping Li 2019-01-14 09:27:36 UTC
The workaround as below:
1) oc edit csv -n openshift-logging, add origin- to the operator images
 quay.io/openshift/origin-cluster-logging-operator:latest
 quay.io/openshift/origin-elasticsearch-operator:latest

 
2) delete the operator deployment
  oc delete deployment cluster-logging-operator
  oc delete deployment elasticsearch-operator

Comment 5 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.