Bug 1665825 - [marketplace] Miss the downstream image for the default marketplace's pod image: "quay.io/openshift/origin-operator-marketplace:latest"
Summary: [marketplace] Miss the downstream image for the default marketplace's pod ima...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Kevin Rizza
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-14 08:18 UTC by Fan Jia
Modified: 2019-06-04 10:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:02 UTC

Description Fan Jia 2019-01-14 08:18:28 UTC
Description of problem:
For now, The default image for marketplace is “quay.io/openshift/origin-operator-marketplace:latest” and this image is upstream image.It would be better if we use the downstream image.

Version-Release number of selected component (if applicable):
clusterversion:4.0.0-9

How reproducible:
always

Steps to Reproduce:
1.Check the marketplace pods running in openshift-marketplace project.
#oc get pods -n openshift-marketplace | grep marketplace
marketplace-operator-676574cb4c-z4sff   1/1       Running   0          12m
2.Check the the image of the marketplace pods
#oc exec marketplace-operator-676574cb4c-z4sff -- cat /etc/redhat-release


Actual results:
We can see the pod is using the upstream image after step 2: 
CentOS Linux release 7.6.1810 (Core)

Expected results:
It would be better if we use the downstream image instead. 
Like the OLM's image:
#oc exec olm-operator-6b444f9df7-t7cfs -- cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.6 (Maipo)


Additional info:

Comment 1 Fan Jia 2019-01-17 06:29:14 UTC
It is ok in clusterversion:4.0.0-0.nightly-2019-01-15-184339

Comment 2 Kevin Rizza 2019-01-17 13:35:39 UTC
Latest version of the installer should be using the OCP image. I believe this is all set.

Comment 3 Fan Jia 2019-01-21 01:51:07 UTC
Latest version of the installer  using the OCP image.

Comment 6 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.