Bug 1665828 - In-correct usage info of binary cluster-version-operator
Summary: In-correct usage info of binary cluster-version-operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.3.0
Assignee: Abhinav Dahiya
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-14 08:35 UTC by Liang Xia
Modified: 2020-01-23 11:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:03:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-version-operator pull 254 0 None closed Bug 1665828: cmd/main.go: fix cli use to cluster-version-operator instead of version 2020-07-12 10:11:07 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:03:59 UTC

Description Liang Xia 2019-01-14 08:35:13 UTC
Description of problem:
Check usage info of binary cluster-version-operator, some misleading info provides. It show the usage is "version [command]", but actually command "version" does not exist.


Version-Release number of selected component (if applicable):
# cluster-version-operator version
ClusterVersionOperator v4.0.0-0.130.0.0-dirty

$ oc adm release info
Name:      4.0.0-0.nightly-2019-01-12-000105
Digest:    sha256:72372c227945f4aedb98bf9bf7df6cda30fed528d24d83d3d5216027569b4394


How reproducible:
Always

Steps to Reproduce:
1. $ oc -n openshift-cluster-version rsh pod/cluster-version-operator-XXXXX
2. sh-4.2# cluster-version-operator --help


Actual results:
sh-4.2# cluster-version-operator --help
Run Cluster Version Controller

Usage:
  version [command]

Available Commands:
  help        Help about any command
  image       Returns image for requested short-name from UpdatePayload
  render      Renders the UpdatePayload to disk.
  start       Starts Cluster Version Operator
  version     Print the version number of Cluster Version Operator

Flags:
      --alsologtostderr                  log to standard error as well as files
  -h, --help                             help for version
      --log_backtrace_at traceLocation   when logging hits line file:N, emit a stack trace (default :0)
      --log_dir string                   If non-empty, write log files in this directory
      --logtostderr                      log to standard error instead of files
      --release-image string             The Openshift release image url.
      --stderrthreshold severity         logs at or above this threshold go to stderr (default 2)
  -v, --v Level                          log level for V logs
      --vmodule moduleSpec               comma-separated list of pattern=N settings for file-filtered logging

Use "version [command] --help" for more information about a command.


sh-4.2# version --help
sh: version: command not found


Expected results:
The usage info should be correct.

Comment 3 Liang Xia 2019-10-29 07:35:24 UTC
Checked on 4.3.0-0.nightly-2019-10-28-222147,

$ oc rsh pod/cluster-version-operator-54774fd8f7-5q58x
sh-4.2# cluster-version-operator --help
Run Cluster Version Controller

Usage:
  cluster-version-operator [command]

Available Commands:
  help        Help about any command
  image       Returns image for requested short-name from UpdatePayload
  render      Renders the UpdatePayload to disk.
  start       Starts Cluster Version Operator
  version     Print the version number of Cluster Version Operator

Flags:
      --add_dir_header                   If true, adds the file directory to the header
      --alsologtostderr                  log to standard error as well as files (default true)
  -h, --help                             help for cluster-version-operator
      --log_backtrace_at traceLocation   when logging hits line file:N, emit a stack trace (default :0)
      --log_dir string                   If non-empty, write log files in this directory
      --log_file string                  If non-empty, use this log file
      --log_file_max_size uint           Defines the maximum size a log file can grow to. Unit is megabytes. If the value is 0, the maximum file size is unlimited. (default 1800)
      --logtostderr                      log to standard error instead of files (default true)
      --skip_headers                     If true, avoid header prefixes in the log messages
      --skip_log_headers                 If true, avoid headers when opening log files
      --stderrthreshold severity         logs at or above this threshold go to stderr (default 2)
  -v, --v Level                          number for the log level verbosity
      --vmodule moduleSpec               comma-separated list of pattern=N settings for file-filtered logging

Use "cluster-version-operator [command] --help" for more information about a command.

Comment 5 errata-xmlrpc 2020-01-23 11:03:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.