Bug 1665861 - Need update jenkins slave image using openshift project in 4.0
Summary: Need update jenkins slave image using openshift project in 4.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-14 09:41 UTC by wewang
Modified: 2019-06-04 10:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:02 UTC

Description wewang 2019-01-14 09:41:55 UTC
Description of problem:
Now in 4.0 jenkins-agent-nodejs-8-rhel7 and jenkins-agent-maven-35-rhel7 are using openshift3 project, should use openshift project
Version-Release number of selected component (if applicable):
jenkins-agent-maven-35-rhel7   v4.0 3bba1b953a1f
jenkins-agent-nodejs-8-rhel7   v4.0 8633d5d950b8
How reproducible:
always

Steps to Reproduce:
1.https://github.com/openshift/jenkins/blob/master/2/contrib/jenkins/kube-slave-common.sh#L27
should change openshift3 to be openshift 
https://github.com/openshift/jenkins/blob/master/2/contrib/jenkins/kube-slave-common.sh#L28
should change openshift3 to be openshift 
2.
3.

Actual results:
jenkins slave use openshift3 project 

Expected results:
should use openshift project 
Additional info:

Comment 2 Ben Parees 2019-01-14 14:56:41 UTC
> FYI, if https://github.com/openshift/jenkins/blob/master/openshift/imagestreams/jenkins-rhel7-ppc64le.json#L41 need update too?

yeah, should be.

Comment 3 Gabe Montero 2019-01-29 19:24:49 UTC
Ben - do you *think* enough pieces of our various openshift/release and ART related activities 
have occurred such that we can mark this done?

Or do you want to gate this one on when the samples operator change drops to tag the jenkins payload
images into the jenkins imagestream?

Also, we could probably make an argument that https://jira.coreos.com/browse/DEVEXP-202 should be used to track
this space vs. this bugzilla, no?

thanks

Comment 4 Ben Parees 2019-01-29 19:26:58 UTC
Let's hold this open until all the payload related changes are in place.  Strictly speaking it's probably a bit redundant, but it'd be good to get explicit QE verification of the slave configuration working correctly once it is switched to use the payload.

Comment 5 Gabe Montero 2019-02-01 16:47:38 UTC
fyi PR https://github.com/openshift/cluster-samples-operator/pull/81 is the last piece of the half dozen or so changes 
wrt getting the jenkins images into the 4.0 payload and tweaking various reference in CI and image startup to leverage
those image ref

Specifically wrt the kube-slave-common.sh config, those image refs in the sample maven/nodejs pod template configs will 
be openshift cluster image registry refs.

Comment 6 Gabe Montero 2019-02-06 03:39:56 UTC
PR marked for merge

Comment 7 Gabe Montero 2019-02-06 20:52:45 UTC
OK with PR https://github.com/openshift/jenkins/pull/775 merging we are done here

Our agent pod template examples will set up the image as a pull spec to the internal registry which actually leverages new imagestreams for the two agent images, where those imagestreams are populated via the release payload

Comment 8 XiuJuan Wang 2019-02-14 08:34:19 UTC
Default to use image-registry.openshift-image-registry.svc:5000/openshift/jenkins-agent-maven:latest and image-registry.openshift-image-registry.svc:5000/openshift/jenkins-agent-nodejs:latest in jenkins server.

$ oc get is -n openshift | grep jenkins 
jenkins                                        image-registry.openshift-image-registry.svc:5000/openshift/jenkins                                        2,latest                                          42 minutes ago
jenkins-agent-maven                            image-registry.openshift-image-registry.svc:5000/openshift/jenkins-agent-maven                            latest,v4.0                                       42 minutes ago
jenkins-agent-nodejs                           image-registry.openshift-image-registry.svc:5000/openshift/jenkins-agent-nodejs                           latest,v4.0                                       42 minutes ago

$ oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-02-13-204401   True        False         36m       Cluster version is 4.0.0-0.nightly-2019-02-13-204401

Comment 11 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.