Bug 1665875 - Should use the downstream image of the Service Catalog
Summary: Should use the downstream image of the Service Catalog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Dan Geoffroy
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-14 10:28 UTC by Jian Zhang
Modified: 2019-06-04 10:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:02 UTC

Description Jian Zhang 2019-01-14 10:28:09 UTC
Description of problem:
By now, the image of Service catalog still is upstream:
[core@ip-10-0-12-46 ~]$ oc exec controller-manager-64b8dd67d-xk49j -- cat /etc/redhat-release
CentOS Linux release 7.6.1810 (Core) 

Version-Release number of selected component (if applicable):
The OLM version:
[core@ip-10-0-37-160 ~]$ sudo podman inspect -f '{{index .ContainerConfig.Labels "io.openshift.source-repo-commit" }}'  registry.svc.ci.openshift.org/ocp/4.0-art-latest-2019-01-12-000105@sha256:778fb8fdf5a74105f0f6c05868b8800be6a40c41697ca1e2e75d48cc27eb241f
81104ffdc4fb3ac29ebf060abd375399ca8f1bea

How reproducible:
always

Steps to Reproduce:
1. Install the Service Catalog via the OLM.
2. Check the image info


Actual results:
The image based on the RHCOS, not the RHEL.
[core@ip-10-0-12-46 ~]$ oc get pods -o yaml -n kube-service-catalog|grep image
      image: quay.io/openshift/origin-service-catalog:v4.0.0

[core@ip-10-0-12-46 ~]$ oc exec controller-manager-64b8dd67d-xk49j -- cat /etc/redhat-release
CentOS Linux release 7.6.1810 (Core) 

Expected results:
We should use the downstream image(based on RHEL), for example, as the OLM did:
[core@ip-10-0-12-46 ~]$ oc exec olm-operator-6b444f9df7-qsnvf -- cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.6 (Maipo)


Additional info:

Comment 1 Jay Boyd 2019-01-15 20:16:32 UTC
Hi Jian.  I am not aware we are supposed to base images on anything other then cent-os.  In fact, when I did an install today off master, I see most images are based on CentOS including openshift-apiserver, openshift-cluster-api, openshift-cluster-machine-approver, openshift-cluster-network-operator, openshift-cluster-node-tuning-operator, openshift-cluster-samples-operator, openshift-cluster-storage-operator, openshift-cluster-version, openshift-console, openshift-controller-manager, openshift-core-operators, openshift-dns, openshift-image-registry, openshift-kube-apiserver, openshift-kube-controller-manager, openshift-kube-scheduler, openshift-machine-config-operator, openshift-monitoring, openshift-sdn, and openshift-service-cert-signer.

Can you point me at any doc or guidance indicating we should be based on RHEL?

Comment 13 Jian Zhang 2019-02-21 02:10:55 UTC
Jay,

> @Jian, can we remove the testblocker label?

Sure, sorry for this, I should have removed it yesterday. Thanks for your workaround, it works well.

Comment 14 Jay Boyd 2019-02-22 19:21:47 UTC
Fixed with https://github.com/openshift/cluster-svcat-controller-manager-operator/pull/18

You will need an OpenShift build after registry.svc.ci.openshift.org/openshift/origin-v4.0@sha256:20aa37313620b76d5ffc133f4e7b824670497e26d3daca42055f58dd3ac22ea1
which lists a created date of "Created": "2019-02-22T01:36:44.282587175Z"

Comment 20 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.