Bug 1666 - netscape crashes when closing a browser window
Summary: netscape crashes when closing a browser window
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: netscape   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-22 12:06 UTC by witten
Modified: 2014-03-17 02:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-22 17:09:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description witten 1999-03-22 12:06:55 UTC
This affects Redhat 5.9:
When multiple netscape browser windows are open, and the
user closes one of them (i.e. with File->Close or by
clicking on the window's close button), then netscape
crashes and all open windows immediately close. The reported
error (at stderr) is "Bus error".

This problem also occurs when the user does File->Exit in
netscape, regardless of how many or few browser windows are
open.

The end of an strace when netscape crashes looks like this:
gettimeofday({922103651, 642529}, NULL) = 0
gettimeofday({922103651, 647846}, NULL) = 0
gettimeofday({922103651, 650471}, NULL) = 0
--- SIGSEGV (Segmentation fault) ---
getpid()                                = 20175
kill(20175, SIGBUS)                     = 0
--- SIGBUS (Bus error) ---
+++ killed by SIGBUS +++

This occurs in both the Netscape 4.08 package included with
Redhat 5.9, and also Netscape 4.50.

Perhaps this is related to bug #1485.

Comment 1 Bill Nottingham 1999-03-22 17:09:59 UTC
should be fixed in XFree86-3.3.3.1-24


Note You need to log in before you can comment on or make changes to this bug.