This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 16660 - PHP modules don't talk to MySQL
PHP modules don't talk to MySQL
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-20 22:35 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-23 01:38:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-20 22:35:58 EDT
MySQL connectivity for exisitng scripts known to work do not work.   I used
a copy of apache and PHP3 that I compiled that work fine on this
installation.
Comment 1 Trond Eivind Glomsrxd 2000-08-21 10:00:16 EDT
Do the database work if you log in manually as the nobody user and execute the
same queries?

And could you elaborate on the "do not work" part?
Comment 2 Trond Eivind Glomsrxd 2000-08-21 15:02:05 EDT
Oh - and how you tried the components in Rawhide?
Comment 3 Need Real Name 2000-08-21 21:15:11 EDT
OK, I fixed this one.  Since I was converting a server over from a RH 6.2
installation I failed to make an "apache" user.  I have I configured the Listen
Directive to listen on port 8000 and tried to start it via
/etc/rc.d/init.d/httpd start and it wouldn't.  When i started it by
/usr/sbin/httpd -D HAVE_PHP4 it gave me the eeror about the apache user.  That
is a change from 6.2 since in 6.2 it ran as nobody.  Though I did create a
"webserver" user to run it under in 6.2.  The PHP module is working OK and is
connecting.  humblest apologies.
Comment 4 Nalin Dahyabhai 2000-08-23 01:38:40 EDT
Looks like I should be closing this one out, then.
Comment 5 Need Real Name 2000-08-23 08:38:25 EDT
yep, go for it....though that machine has stopped responding.  I'll check it
this morning, there may be a new bug report to come.  It had been under attack
from hackers who got into RH6.2 via rpc.statd and then installed the rootkit. 
It required a format and re-install.  I decided to try pinstripe.  If the
hackers are back, they may have crashed it.  It might be time to put up a
"honeypot" RH6.1 machine.    but I digress

Note You need to log in before you can comment on or make changes to this bug.