Bug 166605 - amarok crash with pthreads
amarok crash with pthreads
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-23 15:13 EDT by Emily Brantley
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 08:12:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emily Brantley 2005-08-23 15:13:11 EDT
Description of problem:

amarok will not run unless run with LD_ASSUME_KERNEL=2.2.5 (it crashes,
backtrace for amarokapp below).  with LD_ASSUME_KERNEL=2.2.5, it seems to run
normally.

Program received signal SIGSEGV, Segmentation fault.
---Type <return> to continue, or q <return> to quit---
[Switching to Thread -1208882720 (LWP 22426)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x0022b955 in pthread_once () from /lib/libpthread.so.0
#2  0x0048a95e in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#3  0x004bc2b8 in ?? () from /usr/lib/libGL.so.1
#4  0x0048acb0 in _init () from /usr/lib/libGL.so.1
#5  0xbf942908 in ?? ()
#6  0x00000000 in ?? ()
(gdb)

Version-Release number of selected component (if applicable):

1.3

Additional info:

marking this as high severity, as it cannot be run at all without this
workaround and that without linuxthreads (i.e.: rawhide and FC5) it won't run at
all.

is this an OpenGL bug ?
Comment 1 Michael Schwendt 2005-08-23 16:40:07 EDT
Emily, please fix the Product Version you chose for this ticket,
so we know what distribution release you refer to. Also include the
RPM package version and release. Amarok has not been included in old
fedora.us before FC2.

Please include full unedited output of:

  rpm -qf /usr/lib/libGL.so.1
  rpm -q libstdc++ glibc

Rest assured, Amarok works just fine for a high number of users.
Comment 2 Emily Brantley 2005-08-23 19:25:39 EDT
sorry about the product version and the other missing info.  i was in a hurry. 
thanks.

i know i'm not the only one seeing this, though.  some people in #fedora were
complaining about this very problem, so i installed it for the sole purpose of
filing a bug on their behalf.  sorry for sounding alarmist.  should i reclassify
this with a lower priority ?

$ rpm -qf /usr/lib/libGL.so.1
xorg-x11-Mesa-libGL-6.8.2-37

$ rpm -q libstdc++ glibc
libstdc++-4.0.1-4.fc4
glibc-2.3.5-10

$ rpm -q amarok
amarok-1.3-4.fc4
Comment 3 Michael Schwendt 2005-08-23 21:20:46 EDT
> some people in #fedora were complaining about this very problem

That's the wrong place. If it really bugs them, they ought to submit a
problem report, preferably also at http:/amarok.kde.org

I don't know yet whether Aurelien can reproduce this, but FWIW,
I can't. Only crash I've found during the past hours of test-driving
Amarok 1.3 is a SIGSEGV in xorg-x11 mga_dri.so when switching through
the graphical analysers.

Are there any special steps on how to reproduce a crash like yours?
Can you reproduce it with amarok-debuginfo package installed, so proper
debugging information is included in your backtrace? Your backtrace
does not include any symbols from Amarok, so it's not even clear that
Amarok is the culprit.
Comment 4 Emily Brantley 2005-08-23 21:48:34 EDT
i was unable to locate an amarok-debuginfo of any kind (doing a yum list
amarok*).  i can tell you that the crash is 100% reproducable on my end, and it
appears that the call stack leaves the amarok code well before the crash.  it's
like a threading error in libGL ?  i'm not good enough to figure it out.

i wish someone more capable than i could reproduce it.  all i had to do was yum
install amarok and then try to run it.  nothing special.  for what it's worth,
i'm running nvidia's proprietary drivers.  maybe i should give this a try on the
x.org's nv driver and see if the same thing happens.

okay, here it is ten minutes later (my computer crashed at first, trying to use
two drivers at the same time on different displays, then i rebooted and changed
drivers the real way), and nope, running with the nv driver makes no difference.
 i'm out of ideas, but i don't think i'm the only one seeing it.
Comment 5 Warren Togami 2005-08-23 22:15:58 EDT
Something is extremely odd here, because LD_ASSUME_KERNEL=2.2.5 isn't supposed
to be functional anymore.  LinuxThreads support is no longer in the default
library paths.  See FC4 release notes.

http://fedora.redhat.com/docs/release-notes/fc4/errata/#sn-nptl
Comment 6 Emily Brantley 2005-08-24 00:03:15 EDT
isn't linuxthreads still _available_ in FC4 ?  i know the situation in rawhide
is different.  i had rawhide glibc installed, and the LD_ASSUME_KERNEL trick
fell flat.  downgraded to glibc that came with FC4 and it did indeed let me run
the program.  does that clarify anything ?
Comment 7 Michael Schwendt 2005-08-24 02:55:33 EDT
*-debuginfo packages here:
http://fedoraproject.org/extras/4/i386/debug/

[...]

Re: comment 5 - FC4 still includes the LinuxThreads library paths, also
at run-time, see "LD_ASSUME_KERNEL=2.2.5 ldd ...", it's FC5 that will no
longer be able to compile for LinuxThreads. And yes, that's what the
release notes say.

[...]

> i'm running nvidia's proprietary drivers

I'm not.
Comment 8 Aurelien Bompard 2005-08-24 03:23:53 EDT
I've been running Amarok without problem for the last few days, and I'm using
NVidia's binary drivers.
Comment 9 Emily Brantley 2005-08-24 10:24:25 EDT
i guess my question is, is anybody actually seeing this crash besides me ?  i
could swear a lot of people had complained about it in #fedora, but maybe it's
some obscure corner case after all.

well, i'll get the debuginfo and follow up with a backtrace soon.
Comment 10 Emily Brantley 2005-08-24 10:26:32 EDT
the backtrace is identical with debuginfo installed.
Comment 11 Michael Schwendt 2005-08-24 10:31:22 EDT
Well, then other debuginfo packages are missing for the "in ?? ()"
lines. I fail to see how Amarok is involved when the stracktrace
does not lead back into Amarok's code.
Comment 12 Emily Brantley 2005-08-24 12:22:54 EDT
the only reason amarok is involved is because it somehow causes the crash.  it's
the only thing i know that can cause the crash.

should i do something ?  or should this bug be closed ?
Comment 13 Michael Schwendt 2005-08-24 13:19:14 EDT
Searching Google yields many other problems where glXChannelRectSyncSGIX ()
is involved, even a crash report at nvidia's forum.
Comment 14 Emily Brantley 2005-08-24 13:59:36 EDT
is there a way to use amarok without using /usr/lib/libGL.so.1 ?  so that we can
maybe narrow it down ?

this problem happens whether i use the nv driver or the nvidia driver out of
livna, like i said.

did any of those google hits yield another workaround ?  i guess i'm going to go
look myself right after i post this.
Comment 15 Warren Togami 2005-08-24 18:11:07 EDT
Keep this bug open and talk to upstream about the issue.  This is probably their
responsibility to fix.
Comment 16 Emily Brantley 2005-08-24 20:18:35 EDT
to upstream amarok ?  i personally don't know if i feel motivated to go so far
for a program i don't use...  they'll probably just think it's a fedora specific
thing and close the bug anyways.
Comment 17 Aurelien Bompard 2007-01-11 08:12:41 EST
I'm closing this bug, if it still occurs with the latest version of Amarok
(currently 1.4.4), feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.