Bug 1666149 - all output logs started with 'ERROR: logging before flag.Parse' for apiservice-cabundle-injector
Summary: all output logs started with 'ERROR: logging before flag.Parse' for apiservi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.1.0
Assignee: Erica von Buelow
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-15 03:10 UTC by shahan
Modified: 2019-06-04 10:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:02 UTC

Description shahan 2019-01-15 03:10:59 UTC
Description of problem:
 all output logs started with 'ERROR: logging before flag.Parse'  for apiservice-cabundle-injector however it's a successful event.

Version-Release number of selected component (if applicable):
oc 
v4.0.0-0.123.0
apiservice-cabundle-injector image: io.openshift.build.commit.id": "726b188efdb8c52c72e543ffee182753751a9623",

How reproducible:
Always

Steps to Reproduce:
1. oc logs apiservice-cabundle-injector-7cc897d85b -n openshift-service-cert-signer
2.
3.

Actual results:
<trunked>
ERROR: logging before flag.Parse: I0115 02:43:24.745706 1 option.go:56] APIServiceCABundleInjector: handling update /v1.route.openshift.io ERROR: logging before flag.Parse: I0115 02:43:26.265512 1 leaderelection.go:209] successfully renewed lease openshift-service-cert-signer/openshift-service-serving-cert-signer-apiservice-injector-lock
<trunked>


Expected results:
Should not all logs output have the 'ERROR: logging before flag.Parse' prefix

Additional info:

Comment 2 shahan 2019-03-12 08:52:57 UTC
fix not include in 4.0.0-0.nightly-2019-03-06-074438, waiting for next build

Comment 5 shahan 2019-04-12 03:33:56 UTC
oc logs apiservice-cabundle-injector-6f6ccf4597-j7qrf -n openshift-service-ca |grep APIServiceCABundleInjector
...
I0412 02:40:55.038071       1 option.go:56] APIServiceCABundleInjector: handling update /v1.quota.openshift.io
I0412 02:40:55.054408       1 option.go:56] APIServiceCABundleInjector: handling update /v1.quota.openshift.io
...

Cluster version is 4.0.0-0.nightly-2019-04-10-182914
Verified this bug.

Comment 7 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.